Microsoft Excel

Herbers Excel/VBA-Archiv

In welchem Monat wurde zuletzt gebucht

Betrifft: In welchem Monat wurde zuletzt gebucht von: JoWE
Geschrieben am: 13.09.2014 22:31:59

Hallo Forum,

trotz Excel gut - ich stehe gerade voll auf dem Schlauch!
In den Spalten C bis N der Zeile 3 stehen die Monate Januar bis Dezember. Die Zeilen 4 bis 15 enthalten je Monat (immer) bestimmte (positive) Zahlenwerte. In der Zeile 16 wird die Summe je Spalte berechnet. Nun soll in A1 der Monat ausgegeben werden in welchem zuletzt ein Wert größer Null ausgewiesen ist.
z.B. Jan bis Aug jeweils eine Summe größer 0; in September bis Dezember steht noch immer Null (0). Dann soll in A1 der Monat August ausgegeben werden.

Wie muss die Formel aussehen?

Gruß
Jochen

  

Betrifft: AW: In welchem Monat wurde zuletzt gebucht von: Matze Matthias
Geschrieben am: 13.09.2014 23:38:53

Hallo Jochen,

ich weis nicht ob ich richtig gemacht habe, so hab ich es verstanden:
=INDEX($C$3:$N$3;;VERGLEICH(KKLEINSTE($C$16:$N$16;1);$C$16:$N$16;0)-1)

teste es mal
Gruß Matze


  

Betrifft: AW: In welchem Monat wurde zuletzt gebucht von: JoWE
Geschrieben am: 14.09.2014 11:13:40

Hallo Matze,

danke, die Formel liefert genau das gewünschte Ergebnis.
Du und Erich habt mir echt vom Schlauch geholfen.

Gruß
Jochen


  

Betrifft: letzter Monat mit positivem Wert von: Erich G.
Geschrieben am: 14.09.2014 06:47:45

Hi Jochen,
hier habe ich noch drei alternative Formeln im Angebot:

 BCDEFG
3 JanuarFebruarMärzAprilMai
4    55 
5 2211 33 
6      
7  44   
16Summen22550880
17      
18 Februar    
19 Februar    
20 März    
21 April    

Formeln der Tabelle
ZelleFormel
C16=SUMME(C4:C15)
C18=INDEX($C$3:$N$3;;VERGLEICH(KKLEINSTE($C$16:$N$16;1); $C$16:$N$16;0)-1)
C19=INDEX(C3:N3;;VERGLEICH(MIN(C16:N16); C16:N16;0)-1)
C20=INDEX(C3:N3;ZÄHLENWENN(C16:N16;">0"))
C21{=INDEX(3:3;MAX((C16:N16>0)*SPALTE(C16:N16)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Wenn du schreibst "... stehen die Monate Januar bis Dezember": Stehen da die Namen der NMonate als Texte in den Zellen?
Oder vielleicht auch der jeweilige Monatserste als Datum, mit Zahlenformat MMMM?
Na ja - den Formeln ist das egal. :-)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich und: Schönen Sonntag allerseits!


  

Betrifft: AW: letzter Monat mit positivem Wert von: JoWE
Geschrieben am: 14.09.2014 11:11:38

Hallo Erich,

danke! Alle Formeln liefern genau das gewünschte Ergebnis.
Ich bevorzuge die kürzeste: =INDEX(C3:N3;;VERGLEICH(MIN(C16:N16); C16:N16;0)-1)

Gruß
Jochen


 

Beiträge aus den Excel-Beispielen zum Thema "In welchem Monat wurde zuletzt gebucht"