Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert

Betrifft: Mittelwert von: Janine
Geschrieben am: 17.09.2014 11:11:25

Hallo,

ich hoffe ihr könnt mir helfen. Ich möchte einen Mittelwert vom Verbrauch an Werktagen und Wochenenden berechnen lassen.

Beispiel:
Datum Verbrauch Artikel
01.09.2014 6,3 Birne
02.09.2014 5,2 Birne
03.09.2014 8,9 Birne
04.09.2014 7,7 Birne
05.09.2014 9,1 Birne
06.09.2014 6 Birne
07.09.2014 5,5 Birne

01.09.2014 6,3 Apfel
02.09.2014 5,2 Apfel
03.09.2014 8,9 Apfel
04.09.2014 7,7 Apfel
05.09.2014 9,1 Apfel
06.09.2014 6 Apfel
07.09.2014 5,5 Apfel

01.09.2014 6,3 Kirsche
02.09.2014 5,2 Kirsche
03.09.2014 8,9 Kirsche
04.09.2014 7,7 Kirsche
05.09.2014 9,1 Kirsche
06.09.2014 6 Kirsche
07.09.2014 5,5 Kirsche

Ich komme nicht mit der Einbindung des Datums in die Mittelwertformel klar.

Hat jemand einen Tipp für mich?

Vielen Dank

  

Betrifft: Wenn das pro Produkt sein soll, ... von: Luc:-?
Geschrieben am: 17.09.2014 11:38:27

…Janine,
geht das pro ProduktBlock (hier nur mal für den 1.) zB so:
=SUMMENPRODUKT((WOCHENTAG(A2:A8;2)<6)*B2:B8)/SUMMENPRODUKT(--(WOCHENTAG(A2:A8;2)<6))
=SUMMENPRODUKT((WOCHENTAG(A2:A8;2)>5)*B2:B8)/SUMMENPRODUKT(--(WOCHENTAG(A2:A8;2)>5))
Gruß, Luc :-?


  

Betrifft: AW: Wenn das pro Produkt sein soll, ... von: Janine
Geschrieben am: 17.09.2014 11:53:59

Hallo Luc,

tausend Dank für deine Hilfe. Klappt.

Grüße,
Janine


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert"