Microsoft Excel

Herbers Excel/VBA-Archiv

Excel Makro Hilfe

Betrifft: Excel Makro Hilfe von: Niklas Henkel
Geschrieben am: 18.09.2014 01:40:11

Hallo Excel-Team,

ich versuche es noch einmal genauer zu erklaeren.
Ich habe eine Excel-Tabelle. Diese besitzt in Spalte B immer 2er/3er und 4er Paare an Zahlen und Buchstaben untereinander.
Bsp:
A B
_ ABC 7512384
_ Wtz 0342352.10
_ Wtz 03523512.5

_ ABC 7842135
_ YXS 0323.1523.2

Ich moechte nun, dass mein makro die Zahlen, die nach "ABC" kommen, in Spalte A kopiert, aber nur neben die spalten drunter. (in dem beispiel "7512384" neben die "Wtz" Zellen)

Beispiel aktualisiert:
A B
_______ ABC 7512384
7512384 Wtz 0342352.10
7512384 Wtz 03523512.5

_______ ABC 7842135
7842135 YXS 0323.1523.2

(Unterstrich steht fuer leerzeichen)

Wie erreiche ich das in meinem Makro, sodass Excel auch versteht, dass er manchmal die Zahlen von ABC nur einmal unten rechts von der zelle, in A, kopiert, manchmal 2, manchmal 3 mal? Zur info: Die paare sind immer von einer Leeren spalte abgetrennt.
Bitte schnelle Hilfe :)

  

Betrifft: AW: Excel Makro Hilfe von: Daniel
Geschrieben am: 18.09.2014 01:53:58

Hi
Warum Makro????

folgende Formel in Zelle A2 und dann nach unten ziehen soweit wie benötigt.

=WENN(B1="";"";WENN(B2="";"";WENN(A1="";TEIL(B1;5;999);A1)))

Gruß Daniel


  

Betrifft: AW: Excel Makro Hilfe von: Niklas Henkel
Geschrieben am: 18.09.2014 02:02:51

Und was kommt in die ""? Sorry, bin noch kompletter anfaenger :(


  

Betrifft: AW: Excel Makro Hilfe von: Daniel
Geschrieben am: 18.09.2014 03:07:09

Da ist zunächst mal nichts drin. Wenn was rein soll, kannst du es ja reinschreiben.
Gruß Daniel


  

Betrifft: AW: Excel Makro Hilfe von: Niklas Henkel
Geschrieben am: 18.09.2014 03:22:37

Da kommt bei mir aber immer nach dem einfuegen, dass die formel einen fehler enthaelt. :/


  

Betrifft: AW: Excel Makro Hilfe von: Niklas Henkel
Geschrieben am: 18.09.2014 03:24:57

nach dem einfuegen kommt dann aber immer, dass die formel einen fehler enthaelt :/


  

Betrifft: AW: Excel Makro Hilfe von: Niklas Henkel
Geschrieben am: 18.09.2014 03:32:43

Dann kommt jedoch, dass die formel einen fehler enthaelt :/


  

Betrifft: Dann hast du dich verschrieben! Gruß owT von: Luc:-?
Geschrieben am: 18.09.2014 04:15:01

:-?


  

Betrifft: AW: Dann hast du dich verschrieben! Gruß owT von: Niklas Henkel
Geschrieben am: 18.09.2014 05:11:35

Vielen Vielen Dank!!
habt mir mega geholfen, hatte mich wirklich nur verschrieben.
Kann mir jemand trotzdem nochmal auf deutsch erklaeren was excel da macht?
also ich nehm an, "TEIL(B3,5,999),A3)))" bedeutet: er teilt B3 auf, faengt erst ab dem 5 buchstaben an und dann quasi 999 zeichen (also bis zum ende). Somit fallen die ersten 4 weg.
Aber was bedeuten die ganzen WENN davor?

Bedanke mich schonmal bei allen die mir geholfen haben!


  

Betrifft: AW: Dann hast du dich verschrieben! Gruß owT von: Daniel
Geschrieben am: 18.09.2014 07:39:22

Die wenn's bedeuten das, was du in deiner Frage definiert hast.
Versuche mal genauer zu beschreiben, wann welcher Wert in die Zelle muss, dann solltest du schon dahinterkommen, was die einzelnen Wenn's bedeuten.
Gruß Daniel