Microsoft Excel

Herbers Excel/VBA-Archiv

Anteil Jahresschreiben auf Gesamtdauer

Betrifft: Anteil Jahresschreiben auf Gesamtdauer von: Sören
Geschrieben am: 24.09.2014 15:14:12

Hallo zusammen,

ich stehe mal wieder vor einer neuen Herausfoderung :)

Ich habe folgende Infos in einer Excel Datei:

Wandlänge
Baubeginn (dd.mm.yyyy Format)
Bauende (dd.mm.yyyy Format)

Baubeginn und Bauende können sich auf mehrere Jahre strecken. Jetzt möchte ich den prozentualen Anteil der Wandlänge je Jahresscheibe ermitteln. Die Zahlen sollen als Vergleichswert zum aktuellen IST-Zustand für das lfd. Geschäftsjahr verwendet werden.

Ein Beispiel:
Wandlänge = 500m
Baubeginn = 1.5.2013
Bauende 30.6.2015

Das ergibt folgende Jahresscheiben: 2013 (anteilig- 8 Monate), 2014 (voll- 12 Monate), 2015 (anteilig- 6 Monate). Also insgesamt 26 Monate Bauzeit.

Für 2013 ergäbe dies (8/26)*500 = 153m
für 2014 (12/26)*500 = 230m
für 2015 (6/26)*500 = 115m

Nun die Frage, wie ich dies in Excel abgebildet bekomme :)
Als Auswertungstabelle können die Jahre 2014 bis 2020 nebeneinander jeweils in einer spalte stehen.

Ich sage schon mal vielen Dank und bin sicher, dass es einfacher geht, als gedacht :)

Gruß,
Sören

  

Betrifft: AW: Anteil Jahresschreiben auf Gesamtdauer von: Sven Söllner
Geschrieben am: 24.09.2014 16:22:04

Hi Sören,

hab Dir hier mal was gebastelt.

https://www.herber.de/bbs/user/92796.xlsx

Bei Fragen - fragen...

Grüße
Sven


  

Betrifft: AW: Anteil Jahresschreiben auf Gesamtdauer von: Sören
Geschrieben am: 25.09.2014 11:29:59

Hallo Sven,

schon mal vielen Dank für deine Antwort. Bin der ganzen Sache schon einiges Näher gekommen.
Wenn ich deine Formeln für eine Baumaßnahme, die über mehrere Jahre geht, anwende, haut das alles hin. Nur klappt es irgendwie nicht, wenn die Maßnahme in einem Jahr gebaut wird.
Folgendes wird dann in der Formel berechnet:

Baubeginn 24.1.2014
Bauende 1.3.2014
Die Formel berechnet dann nicht 3 Monate, sondern 12.... also (12/3)*Wandlänge


Ich hoffe ich konnte es einigermaßen veranschaulichen.

Gruß,
Sören


  

Betrifft: OT: Lass endl.d.irreführende r im Betreff weg! owT von: Luc:-?
Geschrieben am: 25.09.2014 12:59:26

:-?


  

Betrifft: AW: OT: Lass endl.d.irreführende r im Betreff weg! owT von: Sven Söllner
Geschrieben am: 26.09.2014 07:52:15

Ändere die Formel in B6 zu

=WENN(A6>JAHR($B$3);"";WENN(JAHR($B$2)=JAHR($B$3);1;WENN(JAHR($B$2)=A6;12-MONAT($B$2)+1; WENN(JAHR($B$3)=A6;MONAT($B$3);12))))

und kopiere diese dann runter... dann läuft es ;-)