Microsoft Excel

Herbers Excel/VBA-Archiv

Formel

Betrifft: Formel von: Zimmer
Geschrieben am: 26.09.2014 13:59:52

Hallo Alle,

mein Anliegen hatte ich bereits in einem anderern Thread erklärt.

Leider ist dieses nun im Archiv (war längere Zeit im Urlaub) und ich habe noch eine Frage..

Zu der Problematik in der Datei:

https://www.herber.de/bbs/user/92566.xlsx

hat mir Jack_d mit folgender Formel geholfen:

für das sheet("mx")ab Zelle A3 und ff
=WENN(ZEILE()-3>SUMME(ISTZAHL(FINDEN("-mx-";Abfrage!M$1:M$100))*1);"";INDEX(Abfrage!B:B;  KKLEINSTE(WENN(ISTZAHL(FINDEN("-mx-";Abfrage!M$1:M$100));ZEILE($1:$100));ZEILE(B1))))  
Das Problem ist nun, dass ich bei A3 + A4 gefundene Zahlen gezeigt bekomme. Bei A5 und A6 ist aber ein #Zahl! Fehler den ich nicht verstehe, da ich die Formel aufgrund meiner wenigen Kentnisse nicht nachvollziehen kann.

  

Betrifft: mit INDEX() und KKLEINSTE() von: neopa C (paneo)
Geschrieben am: 26.09.2014 14:11:26

Hallo,

... nachfolgende Formel: {=WENNFEHLER(INDEX(Abfrage!B:B;KKLEINSTE(WENN(ISTZAHL(FINDEN("-mx-";Abfrage!$M$1:$NM3001)); ZEILE(A$1:A$3001));ZEILE(A1)));"")} nach unten kopieren

liefert die Liste der Nummern (und nur die) für die die Bedingung zutreffend ist

Umrandende { } nicht miteingeben, sondern Formel mit STRG+SHIFT+RETURN abschließen!

Gruß Werner
.. , - ...


  

Betrifft: AW: mit INDEX() und KKLEINSTE() von: Zimmer
Geschrieben am: 26.09.2014 14:40:05

SUPER .. vielen Dank..

die Formel macht nun genau das was ich mir gewünscht habe.. Es gibt allerdings einen kleinen Haken.

Die Tabelle "Abfrage" ist ja dynamisch und es kann vorkommen, dass eine Nummer die kleiner ist oder größer ist dazu kommt. Die Formel sortiert die Ergebnise aber immer so um, sodass die Nummern absteigend sortiert sind. In A3 kann also mal die und auch mal eine andere Zahl sein.

In der Tabelle "mx" werden aber zu der Zelle z.B A3 weiterführende nur zu der nummer passende manuelle Eingaben gemacht, die dann nicht mehr passen, wenn in A3 durch die dynamische Tabelle Abfrage eine andere nummer steht.

Kann ich das irgendwie lösen?


  

Betrifft: die Ergebnisse der Formel sind dynamisch, ... von: neopa C (paneo)
Geschrieben am: 26.09.2014 15:34:36

Hallo,


... wenn in Deiner Tabelle "Abfrage" sich die Werte ändern, ändert sich je nach dessen Inhalt auch das Ergebnis der Formel.

Aber was genau meinst Du mit: "In der Tabelle "mx" werden aber zu der Zelle z.B A3 weiterführende nur zu der nummer passende manuelle Eingaben gemacht,wenn in A3 durch die dynamische Tabelle Abfrage eine andere nummer steht" ?

Kannst Du dies konkreter darlegen?


Gruß Werner
.. , - ...


  

Betrifft: AW: die Ergebnisse der Formel sind dynamisch, ... von: Zimmer
Geschrieben am: 29.09.2014 08:29:29

jou kann ich :)

In der Tabelle "Abfrage" gibt es ganz viele dynamische inhalte. Einer davon ist die Sache mit dem Inhalt "-mx-" der gesucht und die dazu passende Nummer zur Tabelle "mx" übernommen wird. Soweit passt das mit der Formel ja..

In der Tabelle mx habe ich dann die Nummern in der Spalte A nacheinander stehen. in der Spalte B,C,D,E usw. werden per sverweis inhalte die zu der nummer passen aus der Tabelle "Abfrage" gezogen. Soweit kein Problem, weil wenn sich die nummer durch umsortierung ändert, ändert sich der inhalt in sverweis mit.. da dieser sich ja auch die nummer bezieht.

Das Problem ist folgendes: In SPALTE zB. F-J werden manuell kreuze gesetzt. Zur nummer in zb A3 werden manuelle kreuze in F und H gesetzt weil in F Hersteller X und in H Hersteller Y steht. Ändert sich dann irgendwann durch umsortierung in A3 die nummer, passen zwar die sverweis inhalte aber die Hersteller nicht mehr.. da die jetzt neue nummer Hersteller Y und Hersteller Z beinhaltet.

Kann man das verstehen? Ich habe die Datei soweit erweitert.

https://www.herber.de/bbs/user/92869.xlsx


  

Betrifft: dyn. Formellösung und "zugeordnete" Eingaben ... von: neopa C (paneo)
Geschrieben am: 29.09.2014 17:39:54

Hallo,

... das geht/passt nicht zusammen.

Zu Ergebnissen, die erst ermittelt werden kann man keine fixe Eingaben zuordnen, da die Ergebnisse sich ja ändern können, wie Du ja festgestellt hast.
Das muß man strukturell anders anpacken. Wie? Das hängt meist von vielen Fakten ab und kann ich nicht pauschal angeben. Im Prinzip aber oft wieder durch ein abhängigen Bezug (SVERWEIS() oder INDEX() und VERGLEICH() oder VERWEIS() ...) auf eine fixe Datenerfassung.


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Formel"