Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl und Bestellfrequenz

Betrifft: Anzahl und Bestellfrequenz von: giuppy
Geschrieben am: 05.10.2014 12:39:14

Hallo zusammen,

ich möchte kalkulieren der Anzahl der Kunden pro Artikel (es darf nur einmal gezählt werden auch wenn der Kunde mehrmals bestellt hat)
zusätzlich möchte ich auch die bestellt Frequenz nach ein bestimmte Periode kalkulieren
Z.B. Der Kundenanzahl für Artikel 50 ist 7 der monatlich durchschnitt ist 39 und die Bestellfrequenz in Feb ist 9%
Das Ganze soll so dargestellt werden

Artikel Kundenanzahl Mengen Frequenz01 frequenz02 bis Frequenz 12
50 7 320 0% 9%
Anbei Beispiel Tabelle (es können bis 20.000 Zeilen vorhanden sein)
https://www.herber.de/bbs/user/92972.xlsx

Für die Kundenanzahl habe ich mit
{=SUMME(WENN(A1:B10000<>"";1/ZÄHLENWENN(A1:B10000;A1:B10000)))} und mit
SUMMEWENNS($H$2:$H$100;$B$2:$B$100;B2;$A$2:$A$100;A2) probiert aber wird nicht die richtige Zahl dargestellt
Auch mit Pivot wird nicht richtig angezeigt.
Kann mir Jemand helfen
Vielen Dank im voraus

  

Betrifft: mit je einer MATRIXFormel, ... von: neopa C (paneo)
Geschrieben am: 05.10.2014 14:56:18

Hallo giuppy,

... allerdings wird in Spalte F nur eine durchschnittliche "Frequenz" ermittelt.
Formeln nach unten kopieren:

 ABCDEFG
1KundenArtikelMengenDatummonatlich durchschnittdurchschnittl.
Frequenz
Anzahl
21501001.02.143915,9%7
31505005.08.14   
41503002.04.14   
51501003.07.14   
6150503.09.14   
7250220.06.14   
82      
93605005.02.14124,4%5
151601001.01.14   
166602004.02.14   
17760506.08.14   
18760202.06.14   
19860108.07.14   
20860405.03.14   
21860720.09.14   
22860801.10.14   
3113504002.04.14   
321450207.05.14   
331550108.08.14   
3416501005.02.14   
3517501020.02.14   
4215015004.10.14   

Formeln der Tabelle
ZelleFormel
E2{=WENN(ZÄHLENWENN(B$2:B2;B2)=1;RUNDEN(SUMMEWENN(B:B;B2;C:C)/(MAX(WENN(B$1:B$99=B2;D$1:D$99))-MIN(WENN(B$1:B$99=B2;D$1:D$99)))*30;); "")}
F2{=WENN(E2="";"";E2/(MAX(WENN(B$1:B$99=B2;D$1:D$99))-MIN(WENN(B$1:B$99=B2;D$1:D$99))))}
G2{=WENN(E2="";"";WENN(ZÄHLENWENN(B$2:B2;B2)=1;SUMME(N(HÄUFIGKEIT(WENN(B$1:B$99=B2;VERGLEICH(A$1:A$99&"";A$1:A$99&"";)); ZEILE(A$1:A$99))>0)); ""))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl und Bestellfrequenz"