Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung durch Matrix-Vergleich

Betrifft: Bedingte Formatierung durch Matrix-Vergleich von: erichm
Geschrieben am: 05.10.2014 12:35:59

Hallo,

mit der Bedingten Formatierung möchte ich bestimmte Zahlen in der Zeile 2 (=Häufigkeit) einfärben, die in der gleichen Spalte in Zeile 1 eine Zahl haben, die sich in einer (gelben) Matrix befindet. Die Zahlen in der gelben Matrix mit Rahmen erfüllen die Bedingung der Häufigkeit aus Spalte B (Zeile 6 bis 9):

Tabelle3

 ABCDEFGHIJKLMNOPQ
1Anzahl123456789101112131415 
2Häufigkeit2152145183137203512Bed. Formatierung grün Spalte B bis P
3                 
4                 
5                 
6 1 121350174          
7 2 2313259          
8 3 1000134977          
9 4 5312854101          


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Danke.
mfg

  

Betrifft: AW: Bedingte Formatierung durch Matrix-Vergleich von: Christian
Geschrieben am: 05.10.2014 13:10:00

Hallo Erich
Formel für bed. Formatierung in B1:P1 zB. so:

=SUMMENPRODUKT(($D$6:$G$9=B$1)*(SPALTE($D:$G)))>0

Gruß
Christian


  

Betrifft: AW: Bedingte Formatierung durch Matrix-Vergleich von: erichm
Geschrieben am: 05.10.2014 14:43:03

DANKE - funktioniert wunderbar!


  

Betrifft: ZÄHLENWENN() wäre auch ausreichend ... von: neopa C (paneo)
Geschrieben am: 05.10.2014 15:10:31

Hallo,

... so: =ZÄHLENWENN($D6:$G9;B1) oder alternativ =SUMME(0+($D6:$G9=B1)), denn in bedingten Formatierungen bedarf es nicht der MATRIXFunktion SUMMENPRODUKT().

Und nur wenn in D6:D9 Leerzellen sein können und in B1:P1 auch, dann die jeweilige Formel noch mit *(B1<>"") erweitern.


Gruß Werner
.. , - ...


  

Betrifft: DANKE - auch interessant! o.T. von: erichm
Geschrieben am: 05.10.2014 16:04:46

.....


 

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung durch Matrix-Vergleich"