Microsoft Excel

Herbers Excel/VBA-Archiv

Verketten

Betrifft: Verketten von: Alexandra
Geschrieben am: 14.10.2014 16:15:11

Hallo,

habe folgendes Problem in einer Excel-Tabelle.

In Spalte 1 stehen Kundennummern, in Spalte 2 steht Text.

Pro Kundennummer gibt es mehrere Zeilen mit Text.

Ich möchte den Text in Spalte 2 pro Kundenummer in eine Zelle hin verketten.

Problem hierbei - die Anzahl der Zeilen pro Kunde ist sehr unterschiedlich. Mal habe ich für eine Kundennummer 5 Zeilen mit Text, mal nur 1 Zeile, mal 4 etc.

Kundennummer Text Wunschergebnis
1 Montag MontagDienstagMittwochDonnerstagFreitag
1 Dienstag MontagDienstagMittwochDonnerstagFreitag
1 Mittwoch MontagDienstagMittwochDonnerstagFreitag
1 Donnerstag MontagDienstagMittwochDonnerstagFreitag
1 Freitag MontagDienstagMittwochDonnerstagFreitag
2 Januar JanuarFebruarMärz
2 Februar JanuarFebruarMärz
2 März JanuarFebruarMärz
3 2014 2014
4 Frühling FrühlingSommer
4 Sommer FrühlingSommer

Jemand eine Idee, wie ich das verformeln könnte?

Gruß,
Alexandra

  

Betrifft: AW: Verketten von: Oberschlumpf
Geschrieben am: 14.10.2014 16:29:48

Hi Alexandra

a) muss es eine Formellösung sein, oder könnte auch VBA helfen?
b) warum zeigst du uns nicht per Upload (d)eine (Bsp-)Datei?

Ciao
Thorsten


  

Betrifft: AW: Verketten von: Alexandra
Geschrieben am: 14.10.2014 16:41:48

Hallo Thorsten,
VBA geht natürlich auch.
Datei habe ich hochgeladen.
https://www.herber.de/bbs/user/93167.xlsx


Danke :-)


  

Betrifft: AW: Verketten von: Oberschlumpf
Geschrieben am: 14.10.2014 16:58:34

Hi Alexandra

Danke schon mal für die Datei.
Eine Frage hab ich vorhin leider nicht gestellt.
Liegen die Daten IMMER nach Spalte A sortiert vor, oder kann es auch unsortiert sein?

Ciao
Thorsten


  

Betrifft: AW: Verketten von: Alexandra
Geschrieben am: 14.10.2014 17:01:04

Danke Dir fürs Angucken :-)
Ja, die Daten in der Spalte A sind immer sortiert.


  

Betrifft: AW: Verketten von: Oberschlumpf
Geschrieben am: 14.10.2014 18:34:57

Hi Alexandra

So, bin jetzt erst zu hause.
Mit Formeln gehts ja auch - reicht das?

Ciao
Thorsten


  

Betrifft: als Formellösung ... von: neopa C (paneo)
Geschrieben am: 14.10.2014 18:11:31

Hallo Alexandra,

... mit einer Hilfsspalte (kannst Du ausblenden)

Formeln nach unten kopieren:

 ABCDEFGH
1Kundennummer Text Wunschergebnis      
21MontagMontagDienstagMittwochDonnerstagFreitag     Montag
31DienstagMontagDienstagMittwochDonnerstagFreitag     MontagDienstag
41MittwochMontagDienstagMittwochDonnerstagFreitag     MontagDienstagMittwoch
51DonnerstagMontagDienstagMittwochDonnerstagFreitag     MontagDienstagMittwochDonnerstag
61Freitag MontagDienstagMittwochDonnerstagFreitag     MontagDienstagMittwochDonnerstagFreitag
72JanuarJanuarFebruarMärz     Januar
82FebruarJanuarFebruarMärz     JanuarFebruar
92März JanuarFebruarMärz     JanuarFebruarMärz
10320142014    2014
114FrühlingFrühlingSommer    Frühling
124SommerFrühlingSommer    FrühlingSommer
13        
14        

Formeln der Tabelle
ZelleFormel
C2=WENN(A2="";"";VERWEIS(9;1/(A$1:A$99=A2); H:H))
H2=WENN(A2<>A1;B2;H1&B2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: Mit nur einer MxFormel, die auch eine UDF ... von: Luc:-?
Geschrieben am: 14.10.2014 18:28:16

…enthält (und ohne Hilfsspalte!), geht's auch so, Alexandra;
Achtung, einzellige MatrixFormel:
C2[:C12]: {=MxJoin(WENN(A$2:A$12=A2;B$2:B$12;"");" ")}
Falls du kein Trennzeichen zwischen den Texten wünschst, musst du " " durch "" ersetzen. Allerdings enthält die UDF hier noch einen kleinen Fehler, wodurch dann der 1.Buchstabe weggelassen wird. In diesem Fall könntest du dir auch mit C2[:C12]: {=MxJoin(WENN(A$2:A$12=A2;B$2:B$12;"");ZEICHEN(10))} behelfen, was den Vorteil hätte, dass bei Einstellen von Zeilenumbruch jeder Text in eigener Zeile ausgegeben würde.
Gruß, Luc :-?


  

Betrifft: AW: Verketten von: Alexandra
Geschrieben am: 15.10.2014 07:40:57

Vielen Dank Euch allen für die Hilfe.
Problem gelöst :-)
Hat mir eine Menge manueller Arbeit erspart.
Gruß,
Alexandra