Microsoft Excel

Herbers Excel/VBA-Archiv

Excel - Formel

Betrifft: Excel - Formel von: Urs Bartocha
Geschrieben am: 20.10.2014 23:18:37

Hallo zusammen...
Ich hab da ein Problem:
- Ich möchte in einer Zelle eine vierstellige Zahl eingeben z.B. 1212.
wenn ich aber die Zelle verlasse sollte sie abgeändert in : - 12:12 werden
Was oder wie muss ich das anstellen...?
Ich habs schon mit Uhrzeit und mit Zahl - Formatierung versucht, hat aber nicht funz...
Vielen Dank
tigub

  

Betrifft: AW: Excel - Formel von: Matthihas
Geschrieben am: 20.10.2014 23:32:17

Zelle formatieren / Benutzerdefiniert
folgendes Format: -##":"##

Gruss


  

Betrifft: AW: Excel - Formel von: tigub
Geschrieben am: 22.10.2014 10:03:00

Hallo Matthihas

Dieser Benutzerdef. Eingabe haut leider nicht bei einer Eingabe von
- 0001
Bei z.B. 1212 funz es sehr gut: 12:12
Aber eben bei 0001 kommt nur 0:1 und das entspricht nicht dem Wert der Angezeigt werden sollte.
tigub


  

Betrifft: Die Frage ist natürlich, ob das auch eine ... von: Luc:-?
Geschrieben am: 21.10.2014 00:13:24

…(echte) Uhrzeit sein soll, Urs?!
Was Matthias dir vorschlägt, bleibt nämlich (für Berech­nungen) 1212, es sieht nur wie -12:12 aus! Soll es eine echte Uhrzeit wdn, muss man die Zahl erst in die entsprd Bruch­teile eines Tages umrechnen:
=(LINKS(TEXT(A1;"0000");2)+RECHTS(TEXT(A1;"0000");2)/60)/24
Die kannst du dann benutzer­definiert so formatieren: \: - hh:mm (falls ': - ' dazu­gehören soll)
Soll es dagg keine Uhrzeit, sondern nur ein Verhältnis zwischen 2 Zahlen (wie Tore bei Ballspielen) wdn, kannst du das so wie oben oder dauerhaft als TEXT mit der gleich­namigen XlFkt erreichen: =TEXT(A1;"00\:00") oder, falls ': - ' noch dazugehören soll: =TEXT(A1;"\: - 00\:00")
Übrigens kannst du die Angabe zwischen den An-/Aus­führungs­zeichen auch direkt in der Zell­Forma­tierung verwenden!
Gruß, Luc :-?


  

Betrifft: AW: Excel - Formel von: Hajo_Zi
Geschrieben am: 21.10.2014 06:52:56

falls Du hinterher eine Uhrzeit haben möchtest?
http://hajo-excel.de/chCounter3/getfile.php?id=70

GrußformelHomepage


  

Betrifft: AW: Excel - Formel von: tigub
Geschrieben am: 21.10.2014 15:52:39

Vielen Dank für die Formeln

Die Zahlen stehen für eine Uhrzeit (Eishockey), als um 12:12 fiel das Tor...
Aber zur Vereinfachung der Eingabe im Excel möchte ich nur kurz 1212 eingeben.
Das nächste Problem wäre dann, da die Matchuhr rückwärts läuft, aber die Zeit
auf dem Formular vorwärts sein soll:
1. - kurz 1212 ; eingabe im Excel
2. - sollte jetzt 12:12 kommen und eine Zelle weiter die Zahl 08:48 angezeigt werden
3. - je nach drittel natürlich, noch im 1. Drittel 08:48 ; im 2. wäre es demnach 28:48 und
im 3. demnach 48:48. usw.

Kompliziert ich weiss...

Vielen dank
tigub


  

Betrifft: AW: Excel - Formel von: Daniel
Geschrieben am: 21.10.2014 16:08:59

Hi

nehmen wir mal an in A1 steht die Nummer des drittels und in A2 folgend gibst du die Spielzeit ohne Doppelte ein.

in B2 wandelst du mit folgender Formel um:

=WENN(A2="";"";WERT(TEXT(A2;"00"":""00"":""00")))
in C2 berechnest du dann die abgelaufene Spielzeit unter berücksichtigung der 1/3-Nr in Zelle A1
=Wenn(A2="";"";$A$1*Zeit(0;20;0)-B2)
die Zellen formatierst du mit dem Zahlenformat mm:ss

die Formel in B2 und C2 kannst du schonmal soweit nach unten ziehen, wie maximal Tore fallen und ggf diesen Bereich mit Schreibschutz versehen, damit du ihn in der Hektik nicht aus versehen überschreibst.
Mit Makros würde ich bei deinem Kenntnisstand nicht arbeiten.

Gruß Daniel


  

Betrifft: AW: Excel - Formel von: tigub
Geschrieben am: 21.10.2014 23:28:40

Vielen dank, ich werds mal versuchen, ob es so hinhaut...
Werde mich wieder melden...
tigub


  

Betrifft: AW: Excel - Formel von: tigub
Geschrieben am: 22.10.2014 07:35:37

Hallo Daniel

=WENN(A2="";"";WERT(TEXT(A2;"00"":""00"":""00")))
in C2 berechnest du dann die abgelaufene Spielzeit unter berücksichtigung der 1/3-Nr in Zelle A1=Wenn(A2="";"";$A$1*Zeit(0;20;0)-B2)
die Zellen formatierst du mit dem Zahlenformat mm:ss

Haut irgendwie nicht hin - Frage:
- muss bei: - Wert ; - Text ; und - Zeit
was drin stehen?

Wenn nein, stimmt was nicht, da kommen 0,xxxxxxx - Zahlen...

tigub


 

Beiträge aus den Excel-Beispielen zum Thema "Excel - Formel"