Microsoft Excel

Herbers Excel/VBA-Archiv

Lücken zw. mehreren Zeiträumen korrekt ausweisen

Betrifft: Lücken zw. mehreren Zeiträumen korrekt ausweisen von: Bumble
Geschrieben am: 31.10.2014 21:37:59

Hallo an alle,

ich habe ein Problem das ich noch nicht wirklich gelöst bekomme.

Ich habe zu einem Kunden mehrere Zeiträume (die sich teilweise überschneiden). Zwischen diesen Zeiträumen kann es aber auch Lücken geben. Diese möchte korrekt ausweisen als Datum (inkl. von - bis).

Beispiel


ID-------Name-------------von-------------bis
1-----Max Muster---01.01.2010-----31.03.2012
1-----Max Muster---06.07.2014-----laufend
1-----Max Muster---01.01.2012-----20.12.2013
1-----Max Muster---01.01.2014-----04.06.2014
2-----Nico Test------01.09.2011-----14.08.2013
2-----Nico Test------15.12.2013-----15.05.2014
3-----Tina Tür,------01.02.2009-----01.12.2011
3-----Tina Tür-------01.04.2009-----01.12.2011
3-----Tina Tür-------01.06.2011-----laufend

Als Ergebnis müssten die Lückenzeiträume ausgewiesen werden (in einer Spalte daneben):

ID-------Name--------von-------------bis ----------------Lücke von-------Lücke bis
1-----Max Muster---01.01.2010-----31.03.2012----- 21.12.2013------31.12.2013
1-----Max Muster---06.07.2014-----laufend---------05.06.2014------05.07.2014
1-----Max Muster---01.01.2012-----20.12.2013
1-----Max Muster---01.01.2014-----04.06.2014

2-----Nico Test----01.09.2011-----14.08.2013-------15.08.2013------14.12.2013
2-----Nico Test----15.12.2013-----15.05.2014

3-----Tina Tür-----01.02.2009-----01.12.2011-------Keine Lücke
3-----Tina Tür-----01.04.2009-----01.12.2011
3-----Tina Tür-----01.06.2011-----laufend

könntet Ihr mir vielleicht hierbei helfen? Vielen Dank schonmal :)

  

Betrifft: Daten sortieren plus zwei einfache Formeln ... von: neopa C (paneo)
Geschrieben am: 01.11.2014 09:42:39

Hallo,

... die Sortierung für "ID" aufsteigend und gleichzeitig für "von" absteigend. Danch folgende zwei Formeln einfach nach unten kopieren:


 ABCDEF
1IDNamevonbisLücke vonLücke bis
21Max Muster01.01.201031.03.2012  
31Max Muster01.01.201220.12.201321.12.201331.12.2013
41Max Muster01.01.201404.06.201405.06.201405.07.2014
51Max Muster06.07.2014laufend  
62Nico Test01.09.201114.08.201315.08.201314.12.2013
72Nico Test15.12.201315.05.2014  
83Tina Tür,01.02.200901.12.2011  
93Tina Tür01.04.200901.12.2011  
103Tina Tür01.06.2011laufend  
11      

Formeln der Tabelle
ZelleFormel
E2=WENN((B3=B2)*(C3>D2); D2+1;"")
F2=WENN(E2="";"";2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Lücken zw. mehreren Zeiträumen korrekt ausweisen"