Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung

Betrifft: Auswertung von: Kurt h
Geschrieben am: 03.11.2014 21:48:38

Guten Abend,
anbei mein Muster.
Ich krieg es nicht hin die werte per verweis zu errechnnen.
Die roten Ziffern sollen den Nummern zugewiesen werden, die Nummern
stehen in Spalte A ab Zeile 7 und die Summen sollen in die
Spalte D ab Zeile 7 gesetzt werden.
https://www.herber.de/bbs/user/93526.xls
mfg kurt h

  

Betrifft: AW: Auswertung von: Daniel
Geschrieben am: 03.11.2014 22:04:35

Hi

Verweis ist auch nicht für Summenbildung geeignet, sondern dazu um Einzelwerte in einer Menge zu finden.

für dein Beispiel müsste folgende Formel in Zelle D7 (und dann nach unten kopieren)

=WENN((ZÄHLENWENN($W$8:$W$24;A7)+ZÄHLENWENN($AA$8:$AA$24;A7))=0;"";SUMMEWENN($W$8:$W$24;A7;$Y$8:$Y$24)+SUMMEWENN($AA$8:$AA$24;A7;$AC$8:$AC$24))

allerdings sind in deinem Beispiel einige der Zahlen in Spalte Y und AC keine Zahlen sondern Texte (erkennst du an er links- (Text) oder rechtsbündigkeit (Zahl) des Wertes.
Da Excel hier zwischen Zahl und Text unterscheidet, müsstest du darauf achten dass alle Werte Zahlen sind.

Gruß Daniel


  

Betrifft: Es steht nur WAHR .. von: Kurt h
Geschrieben am: 03.11.2014 22:16:07

Hallo Daniel,
es steht nur WAHR in D7 !

mfg kurt h


  

Betrifft: Sind jetzt Zahlen aber von: Kurt h
Geschrieben am: 03.11.2014 22:28:51

Hallo DAniel,
habe in den Formeln die " rausgenommen aber es wird weiter "WAHR"
angezeigt.
mfg
kurt h


  

Betrifft: Nix WAHR (oder "WAHR") von: {Boris}
Geschrieben am: 03.11.2014 23:29:26

Hi Kurt,

wenn ich Daniels Formel in D7 in Deine Beispieldatei kopiere, steht da nie und nimmer WAHR...

VG, Boris


  

Betrifft: AW: Sind jetzt Zahlen aber von: Daniel
Geschrieben am: 03.11.2014 23:30:30

Lade bitte deine Datei hoch.
Gruß Daniel


  

Betrifft: Hat er doch schon bei 1.Frage getan...!? owT von: Luc:-?
Geschrieben am: 04.11.2014 03:10:12

:-?


  

Betrifft: Da ist aber sein "Fehlversuch" nicht drin...oT von: {Boris}
Geschrieben am: 04.11.2014 07:50:22

VG, Boris


  

Betrifft: Aha, na dann... Gruß owT von: Luc:-?
Geschrieben am: 04.11.2014 13:40:21

:-?


  

Betrifft: Warum glaubt mir keiner ? von: Kurt h
Geschrieben am: 04.11.2014 09:48:50

Hallo,
anbei die Musterdatei auch mit WAHR, leider.

https://www.herber.de/bbs/user/93532.xls

mfg Kurt h


  

Betrifft: AW: Formel doppelt drin!! von: hary
Geschrieben am: 04.11.2014 10:03:05

Moin
Du hast die Formel doppelt reingeschrieben.
gruss hary


  

Betrifft: Leider das Gleiche... von: Kurt h
Geschrieben am: 04.11.2014 10:15:13

Hallo Hary,
kannst Du mir mal die Orginal Formel senden, bitte.
Danke im Voraus,
klappt leider nicht,
mfg kurt h


  

Betrifft: AW: Leider das Gleiche... von: hary
Geschrieben am: 04.11.2014 10:22:21

Moin
hab den Thread nicht mitgelesen.
Alte Formel(Formel doppelt drin:



Tabelle1

 ABCD
71NameVornameWahr

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
D7=WENN((ZÄHLENWENN($W$8:$W$24;A7)+ZÄHLENWENN($AA$8:$AA$24;A7))=0;"";SUMMEWENN($W$8:$W$24;A7;$Y$8:$Y$24)+SUMMEWENN($AA$8:$AA$24;A7;$AC$8:$AC$24))
=WENN((ZÄHLENWENN($W$8:$W$24;A7)+ZÄHLENWENN($AA$8:$AA$24;A7))=0;"";SUMMEWENN($W$8:$W$24;A7;$Y$8:$Y$24)+SUMMEWENN($AA$8:$AA$24;A7;$AC$8:$AC$24))
  =IF((COUNTIF(R8C23:R24C23,RC[-3])+COUNTIF(R8C27:R24C27,RC[-3]))=0,"",SUMIF(R8C23:R24C23,RC[-3],R8C25:R24C25)+SUMIF(R8C27:R24C27,RC[-3],R8C29:R24C29))
=IF((COUNTIF(R8C23:R24C23,RC[-3])+COUNTIF(R8C27:R24C27,RC[-3]))=0,"",SUMIF(R8C23:R24C23,RC[-3],R8C25:R24C25)+SUMIF(R8C27:R24C27,RC[-3],R8C29:R24C29))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

Neu:



Tabelle1
 ABCD
71NameVorname3

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
D7=WENN((ZÄHLENWENN($W$8:$W$24;A7)+ZÄHLENWENN($AA$8:$AA$24;A7))=0;"";SUMMEWENN($W$8:$W$24;A7;$Y$8:$Y$24)+SUMMEWENN($AA$8:$AA$24;A7;$AC$8:$AC$24))  =IF((COUNTIF(R8C23:R24C23,RC[-3])+COUNTIF(R8C27:R24C27,RC[-3]))=0,"",SUMIF(R8C23:R24C23,RC[-3],R8C25:R24C25)+SUMIF(R8C27:R24C27,RC[-3],R8C29:R24C29))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: Tausend Dank Hary ! --)) von: Kurt h
Geschrieben am: 04.11.2014 10:27:03

Hallo Hary,
DANKE, hat geklappt.
mfg kurt h


  

Betrifft: Antwort : Weil... von: {Boris}
Geschrieben am: 04.11.2014 14:54:44

Hi,

...ich zwar viel Phantasie habe - aber darauf (doppelt) wäre ich wohl nicht gekommen ;-)

VG Boris


 

Beiträge aus den Excel-Beispielen zum Thema "Auswertung"