Microsoft Excel

Herbers Excel/VBA-Archiv

verschachtete Formel erweitern

Betrifft: verschachtete Formel erweitern von: Andreas
Geschrieben am: 09.11.2014 15:53:43

Hallo Excelprofis,,

mit folgender Formel berechne ich: wenn in D20 ein Wert steht, die Summe der Werte L4:L19 bei denen in J4:J19 eine 1 steht und multipliziere diese Summe mit dem Wert aus D2x2.


=WENN(D20<>"";(D20*2)-(SUMMEWENN(L4:L19;"1";J4:J19));"")

Wie müsste die Formel aussehen, wenn in J4:J19 auch ein b stehen kann.

Also berechne: wenn in D20 ein Wert steht und in J4:J19 eine 1 oder ein b steht.

Ich seh bei diesen verschachteten Formeln nicht durch. Kann mir bitte Jemand helfen!

Danke fürs lesen und die Hilfe!

mfg, Andreas

  

Betrifft: AW: verschachtete Formel erweitern von: Josef B
Geschrieben am: 09.11.2014 16:19:39

Hallo Andreas

Ich hoffe jetzt, dass deine gepostete Formel genau das macht, was sie soll, denn dein Beschrieb passt nicht ganz zu dem, was deine Formel wirklich berechnet.
In diesem Sinne die Erweiterung mit dem zweiten Kriterium:

=WENN(D20<>"";D20*2-SUMME(SUMMEWENN(L4:L19;{1;"b"};J4:J19));"")

Gruss Sepp


  

Betrifft: AW: verschachtete Formel erweitern von: Andreas
Geschrieben am: 09.11.2014 16:25:48

Hallo Sepp,

Sorry, stimmt - habe J mit L verwechselt. Die Formel hat gestimmt.

Danke für die schnelle Hilfe, klappt super.

Schönes WE noch.

mfg, Andreas


  

Betrifft: SUMME(SUMMEWENN von: WF
Geschrieben am: 09.11.2014 16:25:03

Hi,

WENN(D20<>"";(D20*2)-SUMME(SUMMEWENN(L4:L19;{1."b"};J4:J19)))

Salut WF


  

Betrifft: auch dir vielen Dank! Schönes WE noch! owT. von: Andreas
Geschrieben am: 09.11.2014 16:27:17

.


 

Beiträge aus den Excel-Beispielen zum Thema "verschachtete Formel erweitern"