Microsoft Excel

Herbers Excel/VBA-Archiv

Aut. Anpassung der Zeilennummer bei Std-Funktionen

Betrifft: Aut. Anpassung der Zeilennummer bei Std-Funktionen von: Bernd
Geschrieben am: 09.11.2014 15:18:04

Hallo zusammen, ich benötige eure Hilfe und bin überzeugt, dass ihr mir fast sofort helfen könnt.

Ich möchte in einer Exceltabelle die Standardfunktionen wie
Summe, STABW, MIN, MAX usw. automatisch vom Bereich her anpassen, wenn ich am Ende der Tabelle eine Zeile hinzufüge - wenn möglich möchte ich dazu kein Makro verwenden.

Beispiel: Summe (A11:A3486) soll sich, wenn ich die Zeile A3487 kopiere, automatisch ändern in Summe (A11:A3487)
Mit der Funktion Anzahl2(A;A) kann ich die Zeilennummer bestimmen, insofern könnte dies genutzt werden für eine Funktion oder so.

So jetzt steigt der Schwierigkeitsgrad noch etwas.
Noch besser wäre es, wenn ich die Standardfunktionen ohne ein Makro anwenden könnte, wenn die Zeilen zwar schon nach unten kopiert wären, aber z.B. den Wert "0", den Wert "-" oder den Wert "#NV" hätten.

Beispiel:
Die Summe soll gebildet werden ohne Makro von der Zelle A11 bis zur letzten Zelle, die eine Zahl oder ein Datum enthält. Wenn der Wert darunter der Zelle den Wert "-" oder den Wert "#NV" hat, soll die Standardfunktion in der Zelle darüber, also der Zelle mit der letzten Zahl oder Datum aufhören mit der Berechnung.

Zelle A11 hat z.B. den Zahlenwert 11
Zelle A12 bis A3486 hat ebenfalls Zahlenwerte, die auch "0" sein können
A 3487 hat den Wert "-" oder den Wert "#NV"

Nun soll die Summe oder eine andere Standardfunktion gebildet werden von A11 bis A3486.
Wenn nun der Wert der Zelle A3487 von dem Wert "-" oder dem Wert "#NV" aufgrund der Ergänzung von Daten in einem anderen Tabellenblatt umspringt auf einen Zahlenwert, dann soll die Summe gebildet werden von A11 bis A3487 usw.

Warum stelle ich diese Frage: weil ich in der Exceldatei jeden Tag eine Zeile mit neuen Daten hinzufüge und es nervig finde, alle Standardfunktionen in einem Auswerteblatt anpassen zu müssen.

Besten Dank vorab für eure Hilfe!!

  

Betrifft: mit INDEX() und VERWEIS() ... von: neopa C (paneo)
Geschrieben am: 09.11.2014 17:10:51

Hallo,

... ich geh jetzt allerdings davon aus, dass Du mit "-" keinen negativen Wert sondern wirklich das Textzeichen "-" meinst.

Dann =SUMME(A11:INDEX(A:A;VERWEIS(9^9;A:A;ZEILE(A:A))))

und sollte vielleicht auch vor der 11 Zeile eine Zeile eingefügt werden können und trotzdem ab der 11. Zeile berechnet werden, dann eben: =SUMME(INDEX(A:A;11):INDEX(A:A;VERWEIS(9^9;A:A;ZEILE(A:A))))

Und analog für MIN(), MAX() ....

Gruß Werner
.. , - ...


  

Betrifft: AW: Aut. Anpassung der Zeilennummer bei Std-Funktionen von: Bernd
Geschrieben am: 09.11.2014 20:18:55

Besten Dank! Scheint zu Funktionieren :-)

Einen herzlichen Gruß

Bernd


 

Beiträge aus den Excel-Beispielen zum Thema "Aut. Anpassung der Zeilennummer bei Std-Funktionen"