Zeilennummern ausblenden/löschen

Bild

Betrifft: Zeilennummern ausblenden/löschen
von: Achim
Geschrieben am: 02.04.2005 12:10:40
Hallo zusammen!
Ich habe hier ein kleines Problem (vieleicht f. euch)wo ich mir die Zähne
drann ausbeisse. In NC Programmen werden meist mit voranstehenden Zeilennummern vor jedem Satz geschrieben, oder ausgelesen.

Und so sieht's aus:

Beispiel 1
N80 ...
N90 Z50
( Komentar )
N100 X100 Y100
N110 ...
N120 usw.
Wie bekomme ich es hin, das die Zeilennummern N... bis N... (Kann unter Umständen 10000 N-Nummern sein) gelöscht werden und die dahinterfolgenden Weginformationen erhalten bleiben. Manche Zeilen werden auch ohne Zeilennummer ausgewiesen (siehe Beispiel 1). Das Script kann gerne auf Word ausgeführt werden.
Und so soll es fertig aussehen:

...
Z50
( Komentar )
X100 Y100
...
usw.

Danke schon mal im voraus für eure Hilfe !

Bild

Betrifft: AW: Zeilennummern ausblenden/löschen
von: Hajo_Zi
Geschrieben am: 02.04.2005 12:23:41
Hallo Achim,
Tabelle1
 AB
1N80 ......
2N90 Z50Z50
3( Komentar )( Komentar )
4N100 X100 Y100X100 Y100
5N110 ......
6N120 usw.usw.
Formeln der Tabelle
B1 : =WENN(LINKS(A1;1)="N";TEIL(A1;FINDEN(" ";A1)+1;LÄNGE(A1));A1)
B2 : =WENN(LINKS(A2;1)="N";TEIL(A2;FINDEN(" ";A2)+1;LÄNGE(A2));A2)
B3 : =WENN(LINKS(A3;1)="N";TEIL(A3;FINDEN(" ";A3)+1;LÄNGE(A3));A3)
B4 : =WENN(LINKS(A4;1)="N";TEIL(A4;FINDEN(" ";A4)+1;LÄNGE(A4));A4)
B5 : =WENN(LINKS(A5;1)="N";TEIL(A5;FINDEN(" ";A5)+1;LÄNGE(A5));A5)
B6 : =WENN(LINKS(A6;1)="N";TEIL(A6;FINDEN(" ";A6)+1;LÄNGE(A6));A6)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeilennummern ausblenden/löschen"