Microsoft Excel

Herbers Excel/VBA-Archiv

suchfunktion zeilennummer | Herbers Excel-Forum


Betrifft: suchfunktion zeilennummer von: amintire
Geschrieben am: 28.12.2009 22:34:37

Hallo alle zusammen,

ich möchte einen Wert suchen und die Zeilennummer rausbekommen.

A1 = Suchbegriff
B1 = Zeilennummer (Suchbegriff ist in Tabelle2 bei Spalte 1)

Hoffe jemand hat eine Lösung für die Formel.

Vielen Dank.

Gruß amintire

  

Betrifft: AW: suchfunktion zeilennummer von: Daniel
Geschrieben am: 28.12.2009 22:51:48

HI
schau dir mal die VERWEIS-Funktion an, die macht genau das
Gruß, Daniel


  

Betrifft: AW: suchfunktion zeilennummer von: amintire
Geschrieben am: 28.12.2009 22:54:06

Hallo Daniel,

was muss ich als Ergebnisvektor eingeben?
Nur mit Matrix findet die Formel nur dass was ich suche - aber nicht die Zeilennummer.


Gruß amintire


  

Betrifft: =VERGLEICH(A1;Tabelle2!A:A) (oT) von: Jens
Geschrieben am: 28.12.2009 23:16:38




  

Betrifft: AW: suchfunktion zeilennummer von: Ludmila
Geschrieben am: 28.12.2009 22:56:24

endrow = Sheets("Tabelle2).cells(Rows.Count,1).End(xlup).rows
for I = 1 to endrow
if Sheets("Tabelle2").cells(I,1) = Sheets("Tabelle1").cells(1,1) Then
msgbox=rng.adress
end if
next I
gruß
ludmila


  

Betrifft: AW: suchfunktion zeilennummer von: amintire
Geschrieben am: 28.12.2009 22:58:43

Hallo Ludmila,

leider kann ich nicht so gut VBA.
Gibt es keine Lösung mit einer Formel?

Gruß amintire


  

Betrifft: AW: suchfunktion zeilennummer von: tommy
Geschrieben am: 29.12.2009 00:20:03

Schreib mal in Zelle B1 die Formel =VERGLEICH(A1;Tabelle2!A:A)


  

Betrifft: AW: suchfunktion zeilennummer von: tommy
Geschrieben am: 29.12.2009 00:27:31

Sorry!
So ist's richtig:
Zelle B1=VERGLEICH(A1;Tabelle2!A:A;0)


Beiträge aus den Excel-Beispielen zum Thema "suchfunktion zeilennummer"