Microsoft Excel

Herbers Excel/VBA-Archiv

Zeilennummer nach Vergleich 2er Spalten | Herbers Excel-Forum


Betrifft: Zeilennummer nach Vergleich 2er Spalten von: MarkusL
Geschrieben am: 03.02.2010 18:24:00

Hallo,

ich suche verzeifelt eine Lösung für nachfolgendes Problem.

Ich habe eine Tabelle die in der Spalte A und B nach variablen Kriterien durchsucht werden soll. Als Ergebnis, soll die gefunde Zeilennummer zurückgegeben werden. Die Komination der Suchwerte kann in der Tabelle nur einmal vorkommen.

Zeile Spalte A Spalte B
1 10 PR5
2 11 AAU
3 11 PR5
4 10 XYZ

Gesucht wird 11 PR5 ; als Ergnis soll Zeilenummer 3 ausgegeben werden.

Für Ratschläge zur Lösung wäre ich dankbar.

MarkusL

  

Betrifft: AW: Zeilennummer nach Vergleich 2er Spalten von: Uduuh
Geschrieben am: 03.02.2010 18:37:23

Hallo,
Kriterien in D1 und E1
=SUMMENPRODUKT((A1:A4=D1)*(B1:B4=E1)*ZEILE(1:4))

Gruß aus’m Pott
Udo



  

Betrifft: AW: Zeilennummer nach Vergleich 2er Spalten von: MarkusL
Geschrieben am: 03.02.2010 19:14:49

Danke!!!


  

Betrifft: oder als Arrayformel von: WF
Geschrieben am: 03.02.2010 19:15:12

{=VERGLEICH(D1&E1;A1:A9&B1:B9;0)}

Salut WF


Beiträge aus den Excel-Beispielen zum Thema "Zeilennummer nach Vergleich 2er Spalten"