Microsoft Excel

Herbers Excel/VBA-Archiv

Ergebnis aus Vergleich von 2 Spalten schreiben

Betrifft: Ergebnis aus Vergleich von 2 Spalten schreiben von: Peter
Geschrieben am: 02.10.2014 12:58:58

Hallo,

bei einer Tabelle steht in Spalte A Postleitzahlen und in Spalte D zwei verschiedene Werte. Jetzt muss verglichen werden, ob Wert 1 und Wert 2 zu der Postleitzahl passt, oder nur Wert 1 oder Wert 2. Das Ergebnis soll in Spalte K. Und soll entweder 1 oder 2 oder 1/2 sein. Am besten wäre es dann, wenn die restlichen Zeilen mit der gleichen Postleitzahl entfernt wären. Die Postleitzahlen sind sortiert und die jeweils gleichen stehen untereinander.

Ich habe das mit Wenn-Formeln probiert, aber das wird ellenlang und funktioniert nicht wirklich.
Wie bekommt man das besser hin?

Viele Grüße
Peter

  

Betrifft: AW: Bsp.-Mappe fehlt von: hary
Geschrieben am: 02.10.2014 13:17:23

Moin
Bei mir passen immer beide Werte! ;-)))
Lad mal 'ne Bsp.-Mappe hoch. Woher soll Excel wissen welche Werte passen??
gruss hary


  

Betrifft: nicht eindeutig genug ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 13:19:48

Hallo Peter,

... ein auf das Wesentlicher reduzierter Tabellenauszug hier als Datei eingestellt und daran Dein Ziel erklärt, könnte weiter helfen.

Gruß Werner
.. , - ...


  

Betrifft: AW: Ergebnis aus Vergleich von 2 Spalten schreiben von: Peter
Geschrieben am: 02.10.2014 13:54:38

Hier ist die Beispieldatei.

https://www.herber.de/bbs/user/92947.xlsx

Interessant sind nur Spalte A, Spalte D und Spalte K
In Spalte L steht das gewünschte Ergebnis. Die Zeilen, in denen "Zeile entfernt" steht, sollen gelöscht werden. So dass, nur noch jede Postleitzahl einmal vorhanden ist mit dem jeweiliegen Ergebniswert in Spalte K. (10, 20 oder 10/20)


  

Betrifft: Kombination von Formel & Standardfunktionen ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 14:15:31

Hallo Peter,

... (geht mit VBA sicher einfacher) kopiere nachfolgende Formel (momentan für 98 Datensätze) nach unten, Filtere dann in der Spalte K nach "-", markiere die gefilterten Zeilen und lösche diese.

Tabelle1

 ABDK
1PLZCodeSorteWert
2153208250651010/20
31532082507010-
41532082508220-
51532082508620-
6552348250701010
75523482506510-
8972558250822020
99725582508620-
1097255825086  

Formeln der Tabelle
ZelleFormel
K2{=WENN(ZÄHLENWENN(A$1:A2;A2)=1;D2&WENN(MAX((A$2:A$99=A2)*(D$2:D$99<>D2)*D$2:D$99)>0;"/"&MAX((A$2:A$99=A2)*(D$2:D$99<>D2)*D$2:D$99); ""); "-")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Ergebnis aus Vergleich von 2 Spalten schreiben"