Microsoft Excel

Herbers Excel/VBA-Archiv

geht das evtl mit sverweis?

Betrifft: geht das evtl mit sverweis? von: Püschel
Geschrieben am: 11.11.2014 15:40:45

Ausgangspunkt:

Tabelle 1 mit 2 Spalten (Spalte 1 - noch - leer), Spalte 2: beliebiger Text
Tabelle 2 wird die ganze Tabelle anzusprechen sein

Das versuche ich derzeit:

Wenn ich in Tab 1/Spalte 2 einen Text eingebe und dieser in irgendeiner Zelle von Tab 2 vorkommt, soll in Tab 1/Spalte 1 ein X eingetragen werden.

Kann mir jemand einen Tipp geben?

Danke im voraus
Arndt

  

Betrifft: AW: geht das evtl mit sverweis? von: SF
Geschrieben am: 11.11.2014 15:49:21

Hola,

ungetestet:

=wenn(zählenwenn(Tabelle2!A:Z;B1);"x";"")
Als Beispiel für die Spalten A bis Z.

Gruß,
steve1da


  

Betrifft: AW: geht das evtl mit sverweis? von: Michael
Geschrieben am: 11.11.2014 16:09:32

Hallo Arndt!

Ich gehe davon aus, dass der Text in Tabelle 2 in Spalte B steht. Dann brauchst Du in den Zellen von Tabelle 1/Spalte A folgende Formel:

{=WENN(ODER(IDENTISCH($B1;Tabelle2!B:B))=WAHR;"x";"")}

Achtung: Geschwungene Klammern erzeugst Du durch abschließen der Formeleingabe mit Strg+Umschalt+Enter (Matrixformel).

Michael


  

Betrifft: AW: geht das evtl mit sverweis? von: Püschel
Geschrieben am: 11.11.2014 16:34:17

Hallo Ihr Beiden! Vielen Dank1
Bei Michael wird zwar ein x eingetragen, aber auch dann, wenn in Tab 1, 2. Spalte gar nichts steht.
Vermutung: Es werden auch leere Felder verglichen und somit immer ein x angezeigt?

bei steve1da funktioniert es eigentlich gut. wenn ich aber den gesuchten wert aus der Tabelle 2 lösche, bleibt das x noch stehen, wäre aber eine Notlösung.

Danke, etwas hilft das ja schon mal weiter.

Gruß
Arndt


  

Betrifft: das ist so nicht korrekt ... von: neopa C (paneo)
Geschrieben am: 11.11.2014 16:51:40

Hallo Arndt,

... mit Michaels Formel wird nur mit den Werten der 2. Spalte der Tabelle2 vergleichen, Du schriebst aber es soll in der gesamten Tabelle2 untersucht werden. Was gilt? Die Frage ist auch ob, Du wirklich auch die exakt gleiche Schreibweise untersuchen willst, wie Michael getan hat. Das schlaucht den PC ganz schön.

Mit Steve1da wird zwar auch nicht die gesamte Tabelle untersucht aber dafür ist die Formel sehr schnell in der Auswertung und lässt sich auf den vorgegebenen zu untersuchenden Bereich einfach anpassen.


=WENN(ZÄHLENWENN(Tabelle2!$1:$1048576;B3);"x";"")

Wenn das Ergebnis "x" bei dieser Formel stehen bleibt, wenn Du einen Suchwert in Tabelle2 löschst, liegt es daran, dass der gesuchte Wert wo anders eben nochmal steht.


Gruß Werner
.. , - ...


  

Betrifft: AW: geht das evtl mit sverweis? von: Püschel
Geschrieben am: 11.11.2014 16:41:00

STOP! Fehler gefunden! Die Sache von stefe1da funktioniert! Hab nicht daran gedacht, dass ich ja in der Tabelle Spaltenüberschriften habe und musste dazu erst mal aus B1, B2 machen!

Klappt wunderbar!

Danke!

Arndt


 

Beiträge aus den Excel-Beispielen zum Thema "geht das evtl mit sverweis?"