Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Wenn im Bereich

Betrifft: Wenn im Bereich von: Sabrina
Geschrieben am: 11.11.2014 15:01:24

Hallo Leute,

ich suche eine Formel und komme einfach nicht weiter.

Wenn im Bereich N21 - N40 die Zahl 1021,1022,1023,1024 oder 1025 dinnen seht soll eine 1 sonst eine 2 ausgegeben werden.

Ich habe das so versucht .. aber da ist man schnell am Ende

=WENN(N21=1021;"1";WENN(N22=1021;"1";WENN(N23=1021;"1";WENN(N24=1021;"1"; .....

Kann mir jemand helfen?

  

Betrifft: AW: Wenn im Bereich von: Hajo_Zi
Geschrieben am: 11.11.2014 15:07:19


Tabelle7

 NO
2012
211021 
221022 
23  

verwendete Formeln
Zelle Formel Bereich N/A
N20:O20=2-N(SUMME(ZÄHLENWENN(N21:N40;{1021.1022.1023.1024.1025}))>0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.20 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: Funktion N() hier nicht notwendig ... von: neopa C (paneo)
Geschrieben am: 11.11.2014 15:30:25

Hallo,

... ausreichend ist bereits:

=2-(SUMME(ZÄHLENWENN(N21:N40;{1021.1022.1023.1024.1025}))>0)

da ja durch die Subtraktion bereits eine mathematische Operation erfolgt,
die den Wahrheitswert des Teilformelergebnisses
(SUMME(ZÄHLENWENN(N21:N40;{1021.1022.1023.1024.1025}))>0)  
in eine Zahl 0 bzw. 1 wandelt.

Gruß Werner
.. , - ...


  

Betrifft: Danke ... aber von: Sabrina
Geschrieben am: 11.11.2014 15:39:10

Hallo ihr beiden .. Danke.

An einer anderen Stelle habe ich ein ähnliches Problem.

Gleiche voraussetzung nur soll nicht der Wert 1 oder 2 ausgegeben werden sondern wenn eine der Zahlen in dem Bereich N20 - N41 vorhanden ist soll die Zelle leer bleiben, wenn keine der Zahlen vorhanden sind soll eine Formel =WENN(N21="";"";B21*N21) ( und so weiter ) ausgegeben werden.


  

Betrifft: Eine Fml oder doch eher ihr Ergebnis...? ;-) orT von: Luc:-?
Geschrieben am: 11.11.2014 15:41:32

Gruß, Luc :-?

Besser informiert mit …


  

Betrifft: jetzt nicht eindeutig ... von: neopa C (paneo)
Geschrieben am: 11.11.2014 15:58:54

Hallo Sabrina,

... soll wieder der gesamte Bereich in einer Zelle betrachtet/berechnet werden oder dies je Zeile erfolgen?


Gruß Werner
.. , - ...


  

Betrifft: Beispiel hochgeladen von: Sabrina
Geschrieben am: 11.11.2014 16:34:05

Hallo Leute.

Sorry .. habe mich echt undeutlich ausgedrückt
Deswegen habe ich mal eine Mappe hochgeladen.

https://www.herber.de/bbs/user/93687.xls

Wenn im Bereich L15 - L20 die Zahlen 1021, 1022, 1023, 1024 oder 1025 stehen soll im Bereich P21 - P40 eine Null stehen oder leer sein. Ansonsten soll die Formel (z.b in P21 "=WENN(N21="";"";B21*N21)", in P21 "=WENN(N22="";"";B22*N22)" und so weiter stehen.

Gruß Sabrina


  

Betrifft: dann einfach ... von: neopa C (paneo)
Geschrieben am: 11.11.2014 16:50:43

Hallo Sabrina,

... z.B. so: =WENN(ISTZAHL(VERGLEICH(L21;{1021.1022.1023.1024.1025};));0;B21*N21)


Gruß Werner
.. , - ...


  

Betrifft: AW: dann einfach ... von: Sabrina
Geschrieben am: 11.11.2014 16:56:28

Hallo Werner,

so funktioniert es leider nicht, die Formel bezieht sich ja auf die selbe Zeile

Also z.B. in Zelle P21 soll geschaut werden ob im Bereich L15 bis L20 irgendwo die Zahlen 1021,1022...1025 stehen. Dann soll die Zelle leer oder 0 sein, ansonsten =WENN(N21="";"";B21*N21)

Gruß Sabrina


  

Betrifft: dann meinst Du es wohl ... von: neopa C (paneo)
Geschrieben am: 11.11.2014 17:07:00

Hallo Sabrina,

... doch wieder so:

=WENN(SUMME(ZÄHLENWENN(L$15:L$20;{1021.1022.1023.1024.1025}))>0;0;B21*N21)
oder?


Gruß Werner
.. , - ...


  

Betrifft: AW: dann meinst Du es wohl ... von: Sabrina
Geschrieben am: 11.11.2014 22:34:57

Danke :D
So geht es


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn im Bereich"