Microsoft Excel

Herbers Excel/VBA-Archiv

Lieste

Betrifft: Lieste von: Torsten
Geschrieben am: 19.11.2014 22:07:57

Hallo zusammen,
habe wieder ein Problem.

Habe eine Adressenliste bekommen wo in A2 der Name, B2 die Adresse C2 die Tel
und Handy in C3. Dann würde der nächste Name in A4 stehen.

Gibt es eine Möglichkeit die Handynr in D2 zu bekommen?

Es sind viele Datensätze.

Beispieldatei

https://www.herber.de/bbs/user/93886.xlsx

  

Betrifft: Handy in Spalte("D") von: Matthias L
Geschrieben am: 19.11.2014 22:55:57

Hallo

Meinst Du so?

 ABCD
1Kontaktliste  Handy
2SchröderAdresse04341-11110171-111111
3  0171-111111 
4SchmidtAdresse Nr04341-222 
5SchreiberAdresse04522-45860152-21655277
6  0152-21655277 
7MüllerAdresse04341-1330157-74016800
8  0157-74016800 

Formeln der Tabelle
ZelleFormel
D2=WENN(B3="";C3;"")
D3=WENN(B4="";C4;"")
D4=WENN(B5="";C5;"")
D5=WENN(B6="";C6;"")
D6=WENN(B7="";C7;"")
D7=WENN(B8="";C8;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Jetzt nur noch Formeln durch ihre Werte ersetzen in Spalte(D) - fertig.

Gruß Matthias


  

Betrifft: AW: Handy in Spalte("D") von: Torsten
Geschrieben am: 19.11.2014 23:04:54

Klasse,
danke Matthias.
wünsche noch einen schönen Abend.

Gruß Torsten


  

Betrifft: oder mit VBA ... von: Matthias L
Geschrieben am: 19.11.2014 23:03:44

Hallo

Option Explicit

Sub Handy_nach_D()
Dim rng As Range
For Each rng In Range("D2:D8") 'anpassen!
 If rng.Offset(1, -2) = "" Then rng = rng.Offset(1, -1)
Next
End Sub
Gruß Matthias


  

Betrifft: AW: oder mit VBA ... von: Torsten
Geschrieben am: 19.11.2014 23:09:34

Hallo nochmal,
das gefällt mir noch besser.

Gruß Torsten