Automatische Sortierung+Zuordnung per Formel

Bild

Betrifft: Automatische Sortierung+Zuordnung per Formel
von: Joerschi
Geschrieben am: 22.04.2015 21:46:26

Hallo liebes Forum,
ich suche eine Formellösung für folgendes Problem - siehe Skizze (zusammenhängende Daten sind farblich gekennzeichnet):
Userbild
Gegeben ist eine Ausgangstabelle, in der diversen Überschriften darunter Werte zugeordnet sind.
Außerdem ist je Überschrift eine bestimmte Abfolge von horizontalen Zelleninhalten fix vorgegeben (auch als Tabelle).
Es soll nun untereinander - beginnend ab Überschrift 1 - untereinander
1. in Spalte A die Werte eingetragen werden, welche zu Überschrift 1 gehören (danach direkt ohne Leerzeile, die Werte von Überschrift 2 darunter; darunter dann die von Überschrift 3 usw.)
2. in Spalte B der Überschriftsname an sich - zugeordnet zu seinen Werten aus 1.
3. ab Spalte C beginnend nach rechts jeweils nacheinander die in der zweiten Tabelle vordefinierten horizontalen Zelleninhalte.
Für die Skizze oben sähe das gewünschte Ergebnis so aus:
Userbild
Musterdatei: https://www.herber.de/bbs/user/97250.xls
Da die Werte in der Ausgangstabelle dynamisch sind (jedes Mal je Überschrift unterschiedliche Anzahl), wäre es
besonders wichtig, dass bei der Untereinander-Sortierung keine Leerzellen auftreten, sondern dass sie immer direkt an-/untereinander "gepappt" werden.
Hätte jemand eine Idee, wie man bei den Formeln von A23:F23 ansetzen könnte? (die man dann nach unten zieht)
Danke im Voraus und Viele Grüße
Joerschi

Bild

Betrifft: AW: Automatische Sortierung+Zuordnung per Formel
von: Daniel
Geschrieben am: 22.04.2015 22:26:38
Hi
folgendes Formelwerk für deine Tabelle:
Wenn ich als Zielzelle für die Formel einen Zellbereich angebe, so kommt die Formel in die obere linke Zelle und muss in die restlichen Zellen gezogen werden.
Zelle A1: Wert 1
Bereich B1:D1 Formel =ANZAHL(A3:A13)+A1
Bereich B23:B42 Formel =WVERWEIS(ZEILE(A1);$A$1:$D$2;2;1)
Bereich A23:A42 Formel =INDEX($A$3:$D$13;ZÄHLENWENN(B$23:B23;B23);VERGLEICH(B23;$A$2:$D$2;0))
Bereich C23:F42 Formel =WENN($B23=$B22;C22;SVERWEIS($B23;$A$16:$E$19;SPALTE(B$1);1))
Gruß Daniel

Bild

Betrifft: AW: Automatische Sortierung+Zuordnung per Formel
von: Joerschi
Geschrieben am: 22.04.2015 22:49:05
Hallo Daniel,
Danke für Deine Hilfe - ich stehe allerdings etwas auf dem Schlauch.
Welcher Wert kommt in A1? Die Überschrift Ü1 oder der erste Tabellenwert?
Bekomme es irgendwie nicht hin... :-(
Viele Grüße
joerschi

Bild

Betrifft: Doch noch begriffen :-) - Danke nochmals
von: Joerschi
Geschrieben am: 22.04.2015 22:51:32
es war der Wert aus A3

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Automatische Sortierung+Zuordnung per Formel"