Summenprodukt

Bild

Betrifft: Summenprodukt
von: Sandro
Geschrieben am: 05.05.2015 09:56:37

Hallo,
ich steh mal wieder vor einem Problem :D
ich habe in der ersten Spalte verschiedene namen die mehrfach genannt werden. In der der 2. Spalte habe ich Daten oder leer. Nun möchte ich auszählen wie oft Persn x einen Termin (Datum) hat.
Vom Prinzip bräuchte ich eine ZÄHLEnWENN(UND Formel. Ich hab zwar unterschiedliche varianten dieser Formel versucht hat jedoch nie geklappt.Mit dem SUMMENPRODUKT habe ich es leider auch nicht hinbekommen.Ich habe hier bei die Formeln benutzt:(http://www.excelformeln.de/formeln.html?welcher=273). Bei mir kommt immer #WERT!.
Habt ihr eine Idee welche Formel ich dafür verwenden sollte ?
Vielen Dank :)

Bild

Betrifft: AW: Summenprodukt
von: SF
Geschrieben am: 05.05.2015 09:59:37
Hola,
#WERT kommt, wenn im zu zählenden Bereich #WERT steht, oder TEXT - meist die Überschrift.
Ohne zu wissen wo welche Daten stehen kann man nicht mehr sagen.
Gruß,
steve1da

Bild

Betrifft: AW: Summenprodukt
von: Sandro
Geschrieben am: 05.05.2015 10:21:57
Hey,
ich hab geschafft indem ich mein Suchkriterium in "" gesetzt habe. Dummer fehler. Allerdings weiß ich jetzt nicht wie das Suchkriterium für Datum heißt. Ich möchte ja nach namen und Daten suchen.
Meine Formel sieht so aus. =SUMMENPRODUKT((B2:B100="Müller")*(P2:P100="DATUM???")) mit DATUM oder "tt.mm.jjjj" klappt es nicht. Wie muss ich das nennen ?

Bild

Betrifft: AW: Summenprodukt
von: SF
Geschrieben am: 05.05.2015 10:42:10
Hola,
das wäre einfach ">0":

=SUMMENPRODUKT((B2:B100="Müller")*(P2:P100>0))
Alternativ siehe Rudis Beitrag.
Gruß,
steve1da

Bild

Betrifft: AW: Summenprodukt
von: Rudi Maintaire
Geschrieben am: 05.05.2015 10:04:15
Hallo,
so?

ABCDE
1NameTermin NameTermine
2a05.05.2015 a3
3b    
4c05.05.2015   
5a    
6b05.05.2015   
7c05.05.2015   

ZelleFormel
E2=SUMMENPRODUKT((A2:A20=D2)*ISTZAHL(B2:B20))

Gruß
Rudi

Bild

Betrifft: AW: Summenprodukt
von: Sandro
Geschrieben am: 05.05.2015 10:55:17
das ">0" in die Formel einzutragen hat leider nicht funktioniert. Alelrdings hat Rudis Lösungsansatz geklappt. Super Sache. Vielen Dank für die Hilfe.
Schönen Tag noch :)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Auf einmal Laufzeitfehler - Mailanhang"