Kalenderwoche + Feiertag

Bild

Betrifft: Kalenderwoche + Feiertag
von: Sabine
Geschrieben am: 11.05.2015 23:24:17

Hallo zusammen!
Hallo Klexy!
Klexy hat mir bei meinem letzten Problem mit den Soll-Stunden bereits sehr geholfen.
Hier der Beitrag:
https://www.herber.de/forum/archiv/1420to1424/t1420127.htm#1420127
Nun möchte ich unter Kalenderwoche statt Wochenzahl+ggf.Feiertag angezeigt haben, sondern nur Wochenzahl.
Die Formel dazu lautet:
=WENN(A10="";"";WENN(ODER(B7=$B$7;WOCHENTAG(A10;2)=1);TEXT(KÜRZEN((A10-DATUM(JAHR(A10+3-REST(A10-2;7) );1;REST(A10-2;7)-9))/7);"00")&" ";""))&WENN(ISTFEHLER(SVERWEIS(A10;DATEN!A:B;2;FALSCH));""; SVERWEIS(A10;DATEN!A:B;2;FALSCH))
Vielen Dank!

Bild

Betrifft: AW: Kalenderwoche + Feiertag
von: Hajo_Zi
Geschrieben am: 12.05.2015 06:43:41
=Kalenderwoche(B7;21)


Bild

Betrifft: AW: Kalenderwoche + Feiertag
von: Sabine
Geschrieben am: 12.05.2015 07:14:57
Hallo Hajo_Zi,
der sverweis mit "daten!" soll erhalten bleiben. Von dort aus habe ich meine Feiertage, die in der Tabelle mitbeachtet werden müssen.

Bild

Betrifft: AW: Kalenderwoche + Feiertag
von: Hajo_Zi
Geschrieben am: 12.05.2015 07:35:15
Ich Antworte auf das was im Beitrag steht und da Stand Du willst die Kalenderwoche haben.
ersetze =TEXT(KÜRZEN((A10-DATUM(JAHR(A10+3-REST(A10-2;7) );1;REST(A10-2;7)-9))/7);"00") durch meinen kurzen Vorschlag.
Ich sehe Deine Datei nicht und sehe darum auch nicht was Du gelöscht haben willst.
Gruß Hajo

Bild

Betrifft: ;21 erst ab XL2010. owT
von: Rudi Maintaire
Geschrieben am: 12.05.2015 09:13:46


Bild

Betrifft: Kalenderwoche + Feiertag
von: Sabine
Geschrieben am: 16.05.2015 20:51:43
Hier die Datei dazu https://www.herber.de/bbs/user/97677.xls zum ausprobieren.
Bitte um weitere Tipps. Danke!

Bild

Betrifft: AW: Kalenderwoche + Feiertag
von: Rudi Maintaire
Geschrieben am: 12.05.2015 09:11:45
Hallo,
lass einfach
&WENN(ISTFEHLER(SVERWEIS(A10;DATEN!A:B;2;FALSCH));""; SVERWEIS(A10;DATEN!A:B;2;FALSCH))
weg.
Gruß
Rudi

Bild

Betrifft: AW: Kalenderwoche + Feiertag
von: Sabine
Geschrieben am: 12.05.2015 21:31:22
Hallo Rudi,
wenn ich die beiden weglasse, funktioniert es mit den Feiertagen nicht mehr.

Bild

Betrifft: Klexy, wo bist du nur??? Hilfe
von: Sabine
Geschrieben am: 13.05.2015 22:40:56
Hier die reduzierte Version zur Ansicht und zum Ausprobieren:
https://www.herber.de/bbs/user/97640.xls
Vielleicht meldet sich mal auch Klexy selber dazu ;)
Ansonsten bitte weiter versuchen. Bin schon am Ende mit meinem Wissen.
Danke!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kalenderwoche + Feiertag"