SVERWEIS bei mehrspaltigen Suchkriterien

Bild

Betrifft: SVERWEIS bei mehrspaltigen Suchkriterien
von: Gregy
Geschrieben am: 19.05.2015 10:44:39

Hallo,
habe auf der Seite http://www.excelformeln.de/formeln.html?welcher=30
die Formel
=WENN(ZEILE(Z1)>SUMME((A$1:A$99="x")* B$1:B$99="y"));"";INDEX(C:C;KKLEINSTE(WENN((A$1:A$99="x") *(B$1:B$99="y");ZEILE($1:$99));ZEILE(Z1))))
gefunden. Diese gibt mir die jeweilige Zeile aus Spalte C raus, in der sowohl ein X in der jeweilige Spalte A als auch ein Y in der jeweiligen Spalte B verzeichnet ist. Funktioniert auch bei meiner ersten Tabelle (natürlich dementsprechend angepasst) super.
In einem weiteren Tabellenblatt benötige ich allerdings, dass mir zusätzlich noch die jeweiligen Zeilen rausgegeben werden, in denen in Spalte A sowohl ein X als auch ein Z verzeichnet sind (oder-verknüpft). Die Bedingungen der Zeilen aus Spalte B sollen weiterhin so bleiben.
Kann mir hier jemand weiter helfen? Vielen Dank im Voraus
Gregy

Bild

Betrifft: AW: SVERWEIS bei mehrspaltigen Suchkriterien
von: SF
Geschrieben am: 19.05.2015 11:10:31
Hola,
dann ginge das so:

{=WENN(ZEILE(Z1)>SUMME(((A$1:A$99="x")+($A$1:$A$99="z"))*(B$1:B$99="y"));"";INDEX(C:C; KKLEINSTE(WENN(((A$1:A$99="x")+($A$1:$A$99="z"))*(B$1:B$99="y");ZEILE($1:$99));ZEILE(Z1)))) }
Gruß,
steve1da

Bild

Betrifft: AW: SVERWEIS bei mehrspaltigen Suchkriterien
von: Gregy
Geschrieben am: 19.05.2015 12:08:51
Hallo,
vielen Dank für die rasche Antwort. Da ich grad noch entdeckt habe, dass die Grundformel bei mir noch nicht ganz funktioniert, tut sich die Frage auf, was die Befehle Zeile(Z1) am Anfang und am Ende machen?
MfG

Bild

Betrifft: AW: SVERWEIS bei mehrspaltigen Suchkriterien
von: SF
Geschrieben am: 19.05.2015 12:34:49
Hola,
ZEILE() zählt beim runterziehen der Formel immer den Wert um 1 hoch. ZEILE(Z1) bedeutet, dass mit der 1 begonnen wird und dann 1 hochgezählt wird.
Gruß,
steve1da

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS bei mehrspaltigen Suchkriterien"