Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Spezialfilter

Spezialfilter
25.05.2015 13:20:36
ice987
Guten Nachmittag,
Ich möchte folgendes Problem lösen:
Es werden Daten aus einer Datenbank ausgelesen und in Mappe1 gespeichert. In Mappe2 möchte ich nur ausgewählte Daten anzeigen. In diesem Forum habe ich folgende Datei gefunden, welche mein Problem lösen würde:
https://www.herber.de/bbs/user/8478.xls
Können in der Filterzeile nun auch mehrere Werte angegeben und angezeigt werden (z.B. in der Mappe Alex der Index 1 UND 2)?
Vielen Dank für eure Hilfe
Grüsse

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Spezialfilter
25.05.2015 15:41:15
Oberschlumpf
Hi ?
Aber für Alex gibt es im Index nur 1er Werte.
Was genau meinst du?
Ciao
Thorsten

AW: Spezialfilter
25.05.2015 16:30:33
Oberschlumpf
Hi ?
Aber für Alex gibt es im Index nur 1er Werte.
Was genau meinst du?
Ciao
Thorsten

AW: Spezialfilter
25.05.2015 16:48:03
ice987
Hi,
Ich möchte dann in der Mappe Alex alle Werte von Alex (Index 1 ) und alle Werte von Thomas (Index 2) anzeigen lassen.

Kombination Auto- und Spezialfilter
25.05.2015 18:01:54
Michael
Hallo zusammen,
ich habe den Code etwas modifiziert und ein Blatt "Test" angelegt, in dem zwei Kriterien eigegeben werden können (A2 und A3).
Datei: https://www.herber.de/bbs/user/97830.xls
Schöne Grüße,
Michael

Anzeige
AW: Kombination Auto- und Spezialfilter
25.05.2015 19:24:18
ice987
Hallo Michael,
Vielen Dank für deine Bemühungen. Der Code wird sehr kompliziert, da in meiner Tabelle auch noch ein dritter Wert eingefügt werden soll. Gibt es evtl. einen einfacheren Weg dieses Ziel zu erreichen?
Ein Weg wäre auf die Werte der zweiten Mappe direkt auf die erste zu verweisen (Mittels Verknüpfungen) und mittels des Autofilters nur die entsprechenden Werte anzuzeigen. Unglücklicherweise aktualisiert sich dieser bei einem Neueintrag in der ersten Mappe nicht automatisch. Gibt es da eine Möglichkeit?
https://www.herber.de/bbs/user/97831.xlsx

Anzeige
AW: Kombination Auto- und Spezialfilter
25.05.2015 19:37:33
Sepp
Hi,
du sprichst immer von "erster Mappe", "zweiter Mappe" meinst aber Tabellen oder?
Die Beschreibung deines Problemes ist etwas dürftig und unverständlich, vielleicht so.
Tabelle3

 ABCD
1Indizes23 
2    
3IndexWertName 
42100Thomas 
53250Claudia 
6245Thomas 
73600Claudia 
82999Thomas 
93530Claudia 
1028Thomas 
1139Claudia 
1221250Thomas 
133600Claudia 
143650Claudia 
15    
16    
17    

Formeln der Tabelle
ZelleFormel
A4{=WENN(SUMME((Tabelle1!$A$2:$A$100=$B$1:$D$1)*(Tabelle1!$A$2:$A$100<>""))<ZEILE(A1); "";INDEX(Tabelle1!A$2:A$100;KKLEINSTE(WENN((Tabelle1!$A$2:$A$100=Tabelle3!$B$1:$D$1)*(Tabelle1!$A$2:$A$100<>""); ZEILE($1:$99)); ZEILE(A1))))}
B4{=WENN(SUMME((Tabelle1!$A$2:$A$100=$B$1:$D$1)*(Tabelle1!$A$2:$A$100<>""))<ZEILE(B1); "";INDEX(Tabelle1!B$2:B$100;KKLEINSTE(WENN((Tabelle1!$A$2:$A$100=Tabelle3!$B$1:$D$1)*(Tabelle1!$A$2:$A$100<>""); ZEILE($1:$99)); ZEILE(B1))))}
C4{=WENN(SUMME((Tabelle1!$A$2:$A$100=$B$1:$D$1)*(Tabelle1!$A$2:$A$100<>""))<ZEILE(C1); "";INDEX(Tabelle1!C$2:C$100;KKLEINSTE(WENN((Tabelle1!$A$2:$A$100=Tabelle3!$B$1:$D$1)*(Tabelle1!$A$2:$A$100<>""); ZEILE($1:$99)); ZEILE(C1))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Tabelle1

 ABC
1IndexWert Bezeichnung
21100Alex
32100Thomas
43250Claudia
51350Alex
6245Thomas
73600Claudia
81780Alex
92999Thomas
103530Claudia
111200Alex
1228Thomas
1339Claudia
14145Alex
1521250Thomas
163600Claudia
171360Alex
183650Claudia


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
AW: Kombination Auto- und Spezialfilter
25.05.2015 19:34:28
ice987
In Excel gibt's den Button "Erneut übernehmen" , bei welchem der AutoFilter jeweils aktualisiert wird. Gibt's eine Möglichkeit, mit welcher sich dies jeweils beim öffnen der Mappe automatisieren lässt?

AW: Spezialfilter
25.05.2015 18:00:16
Oberschlumpf
Hi ?
Aber für Alex gibt es im Index nur 1er Werte.
Was genau meinst du?
Ciao
Thorsten

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige