Überlappung zweier Zeiträume feststellen

Bild

Betrifft: Überlappung zweier Zeiträume feststellen
von: Florian
Geschrieben am: 26.05.2015 09:38:42

Hallo,
ich habe das Problem, dass ich in Excel prüfen muss, ob sich der Zeitraum (Spalte B und C) in den Datensätzen mit dem vorgegeben Zeitraum (B1 bis B2) überschneidet bzw. überlappt.
Ich habe hier mal die Datei angehängt: https://www.herber.de/bbs/user/97841.xlsx
Ich hoffe, mir kann ja jemand helfen?
Vielen Dank schon mal im Voraus.
Viele Grüße
Florian

Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: Hajo_Zi
Geschrieben am: 26.05.2015 09:52:15
Hallo Florian,
ich hätte vermutet von ist immer kleiner als bis?

Tabelle1

 BCD
5Datensatz vonDatensatz bis Überlappung?
601.08.201431.03.2015Ja
701.04.201531.03.2014Nein
801.04.201431.12.2014Nein
901.01.201528.02.2015Ja
1001.03.201530.09.2015Nein
1101.10.201529.02.2016Nein
1201.03.201631.12.9999Nein
1301.01.201230.11.2004Nein
1402.01.201531.12.9999Ja

verwendete Formeln
Zelle Formel Bereich N/A
D6: D14=WENN(UND(ODER(B6<=$B$1;UND(B6>=$B$1;B6<=$B$2));UND(C6>=$B$2;C6>=$B$1));"Ja";"Nein")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.02 einschl. 64 Bit




Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: EtoPHG
Geschrieben am: 26.05.2015 09:54:02
Hallo Florian,
so:

=WENN(ODER($B$1>C6;B6>$B$2);"Nein";"Ja")

Gruess Hansueli

Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: SF
Geschrieben am: 26.05.2015 09:54:42
Hola,
so?

=WENN(($B$1>=B6)*($B$1<=C6);"ja";"nein")
Gruß,
steve1da

Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: Florian
Geschrieben am: 26.05.2015 10:42:17
Vielen lieben Dank an euch Drei!
Ich habe Eure 3 Vorschläge in der neu angehängten Datei gegenüber gestellt, da es zu fehlerhaften Berechnungen kommt (siehe rote Markierungen). Hier die Datei: https://www.herber.de/bbs/user/97842.xlsx
Ich komm leider nicht auf das Problem. Des weiteren habe ich unten ein zweites Beispiel eingefügt, wo noch weitere Probleme auftreten.
Ich hoffe, jemand kommt auf die Lösung, wie ich das Problem beheben kann?
Viele Grüße
Florian

Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: EtoPHG
Geschrieben am: 26.05.2015 10:47:18
Hallo Florian,
Bei Excel gut, würde ich erwarten, dass eine Formel auch richtig eingesetzt wird.
Im Abschnitt Beispiel 2 beziehen sich mein Formeln, nicht auf deinen angegebene Zeitraum!
Gruess Hansueli

Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: Florian
Geschrieben am: 26.05.2015 10:54:35
Sorry, tut mir wirklich leid.
Aber manchmal sieht man den Wald vor lauter Bäumen nicht mehr!
Trotzdem nochmal Danke. Deine Funktion stimmt!

Bild

Betrifft: AW: Überlappung zweier Zeiträume feststellen
von: Daniel
Geschrieben am: 26.05.2015 11:03:13
Hi
check nochmal dein Beispiel 2
du hast hier nicht überall den Zellbezug für den Zeitraum von-bis von B1/B2 nach B20/B21 verschoben!
ändere das mal in allen Formeln und vergleiche dann die Ergebnisse.
die Formel von Eto rechnet meiner Überprüfung nach immer richtig.
Gruß Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Überlappung zweier Zeiträume feststellen"