Gewinner Tabelle

Bild

Betrifft: Gewinner Tabelle
von: Thomas
Geschrieben am: 27.05.2015 12:02:58

Hallo an die Excel Profis!
ich bin dabei für meine private Kegelbahn eine Tabelle zu machen.
Drin steht der Name vom Spieler, 10 Zeilen für Würfe, unten wird Sumiert. Soweit hab ich es ;)... und jetzt kommt, Oben soll das Programm ein sternchen machen für dem Spieler der die Runde gewonnen hat. Sollte der gleiche Spieler die nächste Runde gewinnen, soll ein Sternchen dazu kommen, bis ich es manuel lösche zb. bei nächsten Spieltag.
Das heisst nochmal im Klartext.
Es soll ein Sternchen oben über dem jewaligen Spieler erst erscheinen wenn alle 10 Würfe gemacht worden sind und wenn er die meiste Punktzahl hat..und bei der nächste Runde wenn er wieder gewinnt, soll ein Sternchen dazu kommen.
puuuu....
hoffe auf Eure Hilfe
Thomas

Bild

Betrifft: AW: Gewinner Tabelle
von: ransi
Geschrieben am: 27.05.2015 12:32:56
Hallo Thomas,
Willst du nach jeder Runde die 10 Würfe löschen oder hast du für jede Runde ein eigenes Tabellenblatt ?
rabsi

Bild

Betrifft: AW: Gewinner Tabelle
von: Thomas
Geschrieben am: 27.05.2015 14:56:47
ich lösche nach jeder Runde die Würfe...die Sterne also Gewonnene Runden sollen bleiben bis ich die manuel lösche

Bild

Betrifft: AW: Gewinner Tabelle
von: fcs
Geschrieben am: 27.05.2015 13:06:12
Hallo Thomas,
Excel kann keine Werte über mehrere Runden automatisch zwischenspeichern.
Nach jeder Runde muss manuell oder per Makro das Ergebnis eingetragen werden - entweder, wie oft ein Mitspieler eine Runde gewonnen hat (dann kann man per Formel die Sternchen erzeugen). oder man trägt die Sternchen in die Zelle ein.
Gruß
Franz

	*		**	
Name	N 01	N 02	N 03	N 04
Wurf 1	6	4	3	8
Wurf 2	8	6	5	6
Wurf 3	5	7	7	7
Wurf 4	9	5	2	9
Wurf 5	7	8	4	8
Wurf 6	3	5	6	9
Wurf 7	8	9	1	5
Wurf 8	9	3	0	6
Wurf 9	9	7	6	8
Wurf 10	9	4	3	6
Punkte	73	58	37	72
Rang	1	3	4	2
Sterne	1		2	
Formeln in Spalte B (können nach rechts kopiert werden bis Spalte M)
B1:	=WIEDERHOLEN("*";B15)
B13:	=SUMME(B3:B12)
B14:	=WENN(ANZAHL($B$12:$M$12)=ANZAHL2($B$2:$M$2);RANG(B13;$B$13:$M$13);"")


Bild

Betrifft: AW: Gewinner Tabelle
von: Thomas
Geschrieben am: 27.05.2015 15:02:37
Hallo Franz,
ja genau..soll automatisch ..also per makro...ein Sternchen dazu eingetragen sein
..muss ich mit "Rang" arbeiten?...reicht nicht das der kuckt ob alle 10 Spalten mit Würfen voll sind, dann einfach größten Wert suchen und dann Makro ausführen für Stern eintragen?

Bild

Betrifft: AW: Gewinner Tabelle
von: Thomas
Geschrieben am: 27.05.2015 15:18:09
https://www.herber.de/bbs/user/97880.xls

Bild

Betrifft: AW: Gewinner Tabelle
von: fcs
Geschrieben am: 27.05.2015 16:34:23
Hallo Thomas,
du kannst die Löschen-Makros entsprechend erweitern, so dass vor dem löschen der Punkte der Sieger ermittelt wird und der Stern ergänzt wird.
Die Zeile

    Call prcWinner(BereichSumme:=Range("C16:H16"))

musst du in alle los-Makros im Modul5 einfügen und dne Berech mit den Summenwerten anpassen.
Gruß
Franz
Sub los6()
'
' los6 Makro
' Makro am 17.05.2015 von innlux aufgezeichnet
'
    Call prcWinner(BereichSumme:=Range("C16:H16"))
'
    Range("C6:H15").Select
    Selection.ClearContents
    Range("C6").Select
End Sub
Sub prcWinner(BereichSumme As Range, Optional Zeile As Long = 4, _
      Optional strZeichen As String = "*")
  'Ermittelt im Bereich den Maxwert und ergänzt in den Spalten mit Maxwert in _
          der Zeile das Zeichen
  Dim dblMax As Double, Spalte As Long
  dblMax = Application.WorksheetFunction.Max(BereichSumme)
  If dblMax > 0 Then
    With BereichSumme
      For Spalte = .Column To .Column + .Columns.Count - 1
        If dblMax = .Parent.Cells(.Row, Spalte).Value Then
          .Parent.Cells(Zeile, Spalte).Value = _
                .Parent.Cells(Zeile, Spalte).Text & strZeichen
        End If
      Next
    End With
  End If
End Sub


Bild

Betrifft: AW: Gewinner Tabelle
von: Thomas
Geschrieben am: 27.05.2015 20:12:45
Wauuuu....super! vielen Dank!!! Funz 100%
Danke Franz!
wenn Du in der Gegend bist komm auf ein Spiel vorbei! ;)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Gewinner Tabelle"