Tabellenbereich exportieren

Bild

Betrifft: Tabellenbereich exportieren
von: Paul
Geschrieben am: 14.06.2015 11:44:32

Hallo,
ich möchte einen dynamischen Bereich einer Tabelle auf einem anderen Arbeitsblatt anzeigen. Ich habe es mit der Pivotfunktion probiert, aber meine Tabelle scheint sich nicht dafür zu eignen, ich hab das vorher aber auch noch nie gemacht... Deswegen frage ich jetzt euch.
Ich habe eine Tabelle mit Dienstzeiten von verschiedenen Mitarbeitern. Nun möchte ich auf einem neuen Blatt einen Mitarbeiter per Dropdown aussuchen und dann ausschließlich seine Daten anzeigen lassen, um sie in eine Zeiterfassungstabelle kopieren zu können.
Da meine Tabelle zu groß ist um sie hier hoch zuladen, habe ich mal die entsprechenden Tabellenblätter kopiert und beigefügt.
Vielen Dank für eure Hilfe!
Paul.
https://www.herber.de/bbs/user/98181.xlsm

Bild

Betrifft: AW: Tabellenbereich exportieren
von: Sepp
Geschrieben am: 14.06.2015 11:59:49
Hallo Paul,
Export

 CDEFGHIJKLM
3 Beginn 1Ende 1Beginn 2Ende 2Beginn 3Ende 3Codes   
4Mo 29.12.1406:00:0007:00:0008:00:0009:00:0022:00:0006:00:00K   
5Di 30.12.1407:00:0008:00:0009:00:0010:00:0022:00:0006:00:00U  Mitarbeiter 1
6Mi 31.12.1408:00:0009:00:0011:00:0012:00:0022:00:0006:00:00K   
7Do 01.01.1509:00:0010:00:0012:00:0013:00:0022:00:0006:00:00U   
8Fr 02.01.1510:00:0011:00:0013:00:0015:00:0022:00:0006:00:00K   
9Sa 03.01.1511:00:0012:00:0015:00:0020:00:0022:00:0006:00:00U   
10So 04.01.1512:00:0013:00:0014:00:0016:00:0022:00:0006:00:00K   

Formeln der Tabelle
ZelleFormel
D4=INDEX(Data4!$B$6:$BZ$33;VERGLEICH($C4;Data4!$A$6:$A$33;0); VERGLEICH($M$5;Data4!$4:$4;0)-2+SPALTE(A$1))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: AW: Tabellenbereich exportieren
von: Paul
Geschrieben am: 14.06.2015 17:24:03
Suuperklasse Sepp! Danke Dir

Bild

Betrifft: kleine Ergänzungsvorschlag ....
von: der neopa C
Geschrieben am: 14.06.2015 14:26:31
Hallo Paul,
... zu Sepps Formel. In Deiner eingestellten Datei stehen Datumswerte, die nicht in der Tabelle Export stehen. Deshalb würde ich die Formel in WENNFEHLER() einbetten.
Bei mir sähe die Formel dann so aus:
=WENNFEHLER(INDEX(Data4!$A:$XFC;VERGLEICH($C4;Data4!$A:$A;);VERGLEICH($M$5;Data4!$4:$4;) -1+SPALTE(A$1));"???")
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Tabellenbereich exportieren"