Diagramm selber bauen

Bild

Betrifft: Diagramm selber bauen
von: Markus
Geschrieben am: 26.06.2015 18:30:20

Hallo zusammen!
Ich schlage mich mit einem für mich komplexen Problem rum und bin für Hilfe sehr dankbar.
Dabei möchte ich Werte aus Excel verwenden, aus denen ich in InDesign (Grafikprogramm) automatisiert Säulen-Diagramme erzeuge. Ein Knackpunkt ist für mich die Berechnung der Höchstwerte aus 15 Spalten für die x-Achse, die zwischen 3000 und 55000 schwanken und deren Unterteilung in 5 bis 8 Teilstriche.
Die Aufrundung plus einer Zugabe von 15% damit die Säulen nicht ganz oben enden habe ich schon hinbekommen.
=AUFRUNDEN((MAX(D2:P2)*115%);-3)
Jetzt fehlt mir nur noch die Logik für die Unterteilungen, die möglichst in 500er-, 1000er-, 2000er-, 5000er-, oder 10000er-Schritten sein sollte.
Vielen Dank für Hinweise!
Markus

Bild

Betrifft: AW: Diagramm selber bauen
von: fcs
Geschrieben am: 27.06.2015 03:42:25
Hallo Markus,
erstelle dir eine Liste mit den Sprüngen der Max-Werte und den zugehörigen Teilungswerte. Dann kannst du den Teilungswert des Diagramms per Formel bestimmen. Ich hab mal 2 Formelvarianten eingebaut.
Gruß
Franz
Tabelle1

 ABCDE
1  KategorieA001A002
2  Wert100002000
3     
4Maxwert12000min.8er-Teilung
5Teilung2000 1000 
6     
7MaxwertTeilung   
80100   
92500500   
1050001000   
11100002000   
12250005000   
135000010000   
1410000020000   

Formeln der Tabelle
ZelleFormel
B4=AUFRUNDEN((MAX(D2:P2)*115%); -3)
B5=SVERWEIS(B4;$A$8:$B$14;2;WAHR)
D5=VERWEIS(B4/D4;B8:B14)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Diagramm selber bauen"