Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung

Betrifft: Bedingte Formatierung von: David Stadelmann
Geschrieben am: 10.07.2015 10:40:24

Hallo zusammen

Ausgangslage
Ich habe in Zelle A1 einen Namen.
Im Bereich B7:B4000 ist dieser Name nebst anderen Namen auffindbar oder auch nicht.

Ziel
Ich möchte, dass die Zelle A1 rot hinterlegt ist wenn: Der Name im Bereich B7:B4000 auffindbar ist. Jedoch nur, wenn hinter dem Namen (Zelle daneben) das Wort "offen" steht. Ansonsten (nicht auffindbar oder ein anderes Wort = grün).

Wäre cool jemand könnte helfen.

  

Betrifft: AW: Bedingte Formatierung von: SF
Geschrieben am: 10.07.2015 10:50:08

Hola,

färbe A1 grün.

Als Formel in der bedingten Formatierung:

=SVERWEIS(A1;B7:C4000;2;0)="offen"
Gruß,
steve1da


  

Betrifft: AW: Bedingte Formatierung von: David Stadelmann
Geschrieben am: 10.07.2015 11:02:54

Danke

Nicht ganz das was ich wollte.

Vielleich habe ich mich auch nicht ganz richtig ausgedrückt.
Im Bereich B7:C4000 kann sein das es so steht:

David bezahlt
Sabrina offen
David bezahlt
David offen

Jetzt möchte ich, dass A1 grün ist solange der Name im Bereich B7:C4000 NICHT gelistet ist.
Ebenfalls soll A1 grün sein solange hinter jedem gleichen Namen (wie A1) bezahlt steht.
Sobald im Bereich B7:C4000 min. einmal der gleiche Name wie in A1 auftaucht und dahinter "offen" steht soll es rot sein.


  

Betrifft: AW: Bedingte Formatierung von: SF
Geschrieben am: 10.07.2015 11:07:53

Hola,

hast du es ausprobiert?

Meine Formel färbt rot, wenn der Name aus A1 im Bereich B7:B4000 vorkommt und gleichzeitig in C7:C4000 "offen" steht.

Gruß,
steve1da


  

Betrifft: AW: Bedingte Formatierung von: David Stadelmann
Geschrieben am: 10.07.2015 11:11:14

Da hast Du schon recht Steve

Aber Deine Formel funktioniert nur, wenn beim der ersten Zeile wo der Name übereinstimmt dahinter "offen" steht. Ist die erste gefundene Zeile mit "bezahlt" sucht Deine Formel nicht weiter...


  

Betrifft: AW: Bedingte Formatierung von: SF
Geschrieben am: 10.07.2015 11:15:58

Hola,

sorry, du hast Recht:

=ZÄHLENWENNS(B7:B4000;A1;C7:C4000;"offen")
Gruß,
steve1da


  

Betrifft: AW: Bedingte Formatierung von: Matthias L
Geschrieben am: 10.07.2015 11:24:44

Hallo

=SUMMENPRODUKT((B7:B400=A1)*(C7:C400="offen"))>0

Gruß Matthias


  

Betrifft: AW: Bedingte Formatierung von: David Stadelmann
Geschrieben am: 10.07.2015 11:34:21

Hallo Jungs


Ihr habt mir perfekt geholfen. Super!!!!


 

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung"