Feste Summe variable Einzelwerte

Bild

Betrifft: Feste Summe variable Einzelwerte
von: Jens
Geschrieben am: 26.07.2015 20:11:05

Hallo,
ich habe da ein Problem in das ich mich überhaupt nicht reindenken und auf eine Exceltabelle übertragen kann.
Hoffe es kann jemand helfen oder das Problem lässt sich überhaupt lösen. Habe leider keinen Ansatz.
Bsp. vereinfacht:
%
Mehl 50
Wasser 15
Zucker 20
Fett 10
Stärke 5
------
100
Wenn ich die 15 % Wasser nun auf 3 % runter nehme, soll die Summe automatisch trotzdem bei 100 % bleiben indem sich die 12 % die ich entfernt habe auf die anderen Werte aufteilt. Diese 12 % sollen sich aber nicht zu gleichen Teilen auf Mehl, Zucker, Fett und Stärke aufteilen, sondern dementsprechend wie stark schon die prozentuale Gewichtung ist.
Lässt sich das irgendwie in Excel umsetzen? Ich bin für jede Hilfe dankbar.
Danke und viele Grüße.

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Besserwisser
Geschrieben am: 26.07.2015 21:49:49
Hallo Jens,
man kann mit nachfolgender Formel auch mehrere Positionen anpassen...
A11: Mehl
A12: Wasser
...
B11: 50%
B12: 15%
Veränderung: in Spalte C:,C12: -12%, Rest in Spalte C ist leer
Spalte D: Gewichtung neu beginnend mit nachfolgender Formel in D11 nach unten kopiert:
=WENN(C11<>"";B11+C11;B11*(SUMMENPRODUKT($B$11:$B$15;--($C$11:$C$15=""))-SUMME($C$11:$C$15)) /SUMMENPRODUKT($B$11:$B$15;--($C$11:$C$15="")))
Viel Spaß
Christian N.

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Jens
Geschrieben am: 27.07.2015 10:15:53
Hallo,
Vielen Dank für eure Antworten. Bin erstaunt und wäre da glaub ich nie drauf gekommen wie das gerechnet wird...
Im Bespiel funktioniert es auf jedenfall :) Ich bekomme aber leider etwas anderes wenn ich versuche es auf mehr Rohstoffe umzumünzen. Kannst du mir sagen was ich falsch mache Christian? Kann ich dir dazu irgendwie die Datei schicken oder so?
Danke und viele Grüße,
Jens

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Besserwisser
Geschrieben am: 27.07.2015 11:23:58
Hallo Jens,
überprüfe in der Formel mal alle Bereiche, ob diese identisch und groß genug sind C11:c16, b11:b16...
Viele Grüße
Christian

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Jens
Geschrieben am: 27.07.2015 11:43:20
Hallo Christian,
die formel ist identisch wie in dem Bsp wo es funktioniert...
Hab mal einen Screenshot davon gemacht.
Userbild
Danke und Grüße

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Besserwisser
Geschrieben am: 27.07.2015 12:56:18
B11:B34, c11:c34

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Jens
Geschrieben am: 27.07.2015 19:02:27
Hey,
Ja macht Sinn. Sorry :D
Vielen Dank, funktioniert super;)
Find das beeindrucken, wie kommt man darauf so eine Formel zusammen zu stellen?
Hab da keinen Ansatz!
Grüße

Bild

Betrifft: AW: Feste Summe variable Einzelwerte
von: Besserwisser
Geschrieben am: 28.07.2015 00:10:45
Hallo Jens,
freut mich, wenn ich Dir helfen konnte.
Gruß
Christian N.

Bild

Betrifft: oben ist einfacher
von: WF
Geschrieben am: 28.07.2015 07:54:06
siehe:
"variabel"
mit darunter
"die Hilfsspalte ..."
WF

Bild

Betrifft: nur mal für Dein Beispiel
von: WF
Geschrieben am: 26.07.2015 22:37:25
Hi,
in B1 bis B5 stehen die Ursprungsbeträge 50 - 15 - 20 - 10 - 5
in C2 der neue Wert: 3
Das Ergebnis dann in D1:
=WENN(C1>0;C1;B1+B1*(B$2-C$2)/(100-B$2))
bis D5 runterkopieren
WF

Bild

Betrifft: AW: nur mal für Dein Beispiel
von: Besserwisser
Geschrieben am: 27.07.2015 06:30:31
Hallo,
In c2 steht -12%
Gruß
Christian N.

Bild

Betrifft: nö
von: WF
Geschrieben am: 27.07.2015 07:59:34
ich zitiere:
"Wenn ich die 15 % Wasser nun auf 3 % runter nehme, ..."
statt 15 also 3
12 werden verteilt
WF

Bild

Betrifft: variabel
von: Michael
Geschrieben am: 27.07.2015 21:36:16
Hi zusammen,
X ist manchmal einfach widerspenstig (oder liegt's an meinem Hirn?).
Ohne Hilfsspalte bekomme ich's nicht hin, aber immerhin: ich erweitere WFs Formel so, daß sie variabel einsetzbar ist.
Datei anbei: https://www.herber.de/bbs/user/99106.xls
Schöne Grüße,
Michael

Bild

Betrifft: die Hilfsspalte aufzulösen ist ja nun einfach
von: WF
Geschrieben am: 27.07.2015 22:13:59
Hi,
in D1 Deiner Tabelle:
=WENN(C1<>0;C1;B1*(B$7-C$7)/SUMMEWENN(C$1:C$6;"";B$1:B$6))
WF

Bild

Betrifft: danke,
von: Michael
Geschrieben am: 29.07.2015 15:48:44
WF,
manchmal ist man einfach vernagelt...
Gruß,
Michael

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Feste Summe variable Einzelwerte"