Anführungsstriche gehen verloren bei Copy

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
ListBox
Bild

Betrifft: Anführungsstriche gehen verloren bei Copy
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 14:47:04

Hallo zusammen,
folgendes Problem:
In VBA ist untenstehender Code.
Es soll eine Formel kopiert werden.
Beim kopieren wird jedes Mal ein Teil der Anführungsstriche verloren.
In der Formel
=Wenn(A54="";"";zählenwenn(C18:C39;Schichtmodelle!$A$5))
Nach dem Copy-Befehl sieht die Formel so aus:
=Wenn(A54=";";zählenwenn(C18:C39;Schichtmodelle!$A$5))
Es fehlt also jedes Mal ein Teil der Anführungsstriche bei ..A54="";""...
Hat jemand eine Idee ?? Wäre super.
Danke und Gruß
Hans
Nachfolgend ein Auszug aus dem Code:
If ListBox1.Value = "Hilfskraft" Then
Application.ScreenUpdating = False
Cells(52, 3).FormulaLocal = "=Wenn(A52="";"";ZÄHLENWENN(c18:c39;Schichtmodelle!$A$5))"
Cells(55, 3).FormulaLocal = "=ZÄHLENWENN(c18:c39;Schichtmodelle!$A$6)"
Cells(58, 3).FormulaLocal = "=ZÄHLENWENN(c18:c39;Schichtmodelle!$A$13)"
Cells(64, 3).FormulaLocal = "=ZÄHLENWENN(c18:c39;$A$64)"
Cells(65, 3).FormulaLocal = "=ZÄHLENWENN(c18:c39;$A$65)"
Cells(66, 3).FormulaLocal = "=ZÄHLENWENN(c18:c39;$A$66)"
Cells(67, 3).FormulaLocal = "=ZÄHLENWENN(c18:c39;$A$67)"
For i = 4 To 33
Cells(52, 3).Copy
Cells(52, i).PasteSpecial

Bild

Betrifft: AW: Anführungsstriche gehen verloren bei Copy
von: Hajo_Zi
Geschrieben am: 01.08.2015 14:48:56
sollten "" nicht durch """" ersetzt werden?


Bild

Betrifft: AW: Anführungsstriche gehen verloren bei Copy
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 15:29:20
Hallo Hajo,
JAAAAAAAA, Super, klappt
Danke für die super-Schnelle Hilfe!!!
Viele Grüße
Hans

Bild

Betrifft: Danke für Rückmeldsung oT
von: Hajo_Zi
Geschrieben am: 01.08.2015 15:31:06


Bild

Betrifft: AW: Anführungsstriche gehen verloren bei Copy
von: Werner
Geschrieben am: 01.08.2015 15:27:38
Hallo Hans-Joachim,
was Hast dir damit sagen will ist folgendes: Schreibst du eine Formel in einen Vba Code dann mü _ ssen innerhalb der Formel im Code die "" immer doppelt vorhanden sein damit Vba das als Teil der Formel erkennt. In deinem Fall also:


"=Wenn(A52="""";""""..........
Gruß Werner

Bild

Betrifft: AW: Anführungsstriche gehen verloren bei Copy
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 15:48:58
Hallo Werner,
vielen Dank für Deinen ergänzenden Hinweis. Jetzt hab ich wieder etwas dazu gelernt.
Klappt, Danke!
Gruß
Hans

Bild

Betrifft: AW: Danke für die Rückmeldung. owT
von: Werner
Geschrieben am: 01.08.2015 18:19:05


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Anführungsstriche gehen verloren bei Copy"