formel stabiler machen

Bild

Betrifft: formel stabiler machen
von: Thomas
Geschrieben am: 05.08.2015 19:17:04

Hallo Excelfreunde,
weiss jemand von euch wie ich die untenstehenden Formel stabiler machen kann?
Ich meine wenn ich im Blatt "Auswertung Allgemein" eine spalte lösche geht diese Formel dabei kaputt #NV und führt zum Fehler.
Formel =SUMMENPRODUKT(('Auswertung Allgemein'!$A10:Z10=$A2)*SPALTE(A:Z))
hab schon ne Menge mit index probiert aber irgentwie kriege ich es nicht hin.
vielen dank schon mal
liebe grüsse thomas

Bild

Betrifft: AW: formel stabiler machen
von: Daniel
Geschrieben am: 05.08.2015 19:25:01
Hi
in der Summenprodukt-Formel (und in anderen Matrixformln) musst du darauf achten, dass die Matrixrelevanten Zellbereiche immer gleich gross sind.
Ansonsten findet eine Zelle aus dem einen Block keinen Partern aus dem anderen Zellbock und dann gibts den Fehler.
Daher:

=SUMMENPRODUKT(('Auswertung Allgemein'!$A10:Z10=$A2)*SPALTE('Auswertung Allgemein'!A:Z))
denn es sollte egal sein, aus welchem Blatt du die Spaltennummern ausliest.
Gruß Daniel

Bild

Betrifft: super klappt besten dank Daniel
von: Thomas
Geschrieben am: 05.08.2015 19:57:50
Hallo Daniel,
schon das zweite mal heut vielen dank für die tipps.
Klappt bestens und gelernt habe ich auch mal wieder.
vielen dank
liebe grüsse thomas

 Bild

Beiträge aus den Excel-Beispielen zum Thema "formel stabiler machen"