Spalten abfragen

Bild

Betrifft: Spalten abfragen
von: Smanb
Geschrieben am: 16.08.2015 20:22:05

Hallo...ich habe mit Excel erst vor einer Woche angefangen und versuche einen Schichtplan zu machen...
Ich möchte nun folgendes erreichen und komme nicht weiter:
vereinfacht:
WENN in Spalte A ein N (kommt immer nur alleine vor) vorkommt ODER wenn ich Spalte B irgendwo eine 21 (steht als Uhrzeit zB 21:12) steht dann schreibe in Zelle C1 eine 40.
wollte das irgendwie so umsetzen, komme aber nicht drauf wie es funktionieren könnte...
=WENN(ISTFEHLER(VERGLEICH("N";$D$6:$D$36;0));0;WENN(ISTFEHLER(VERGLEICH("21";$G$6:$G$36;0));0;40,4))
danach wollte ich es damit versuchen..
=(SUMMENPRODUKT((D6:D36="N")+((G6:G36>=0,875)*(D6:D36<=0,915973)))>0)*40
diese Formel erkennt aber leider die 21 nicht wenn sie innerhalb der Uhrzeit steht sondern nur alleine...
jemand eine Idee?

Bild

Betrifft: AW: Spalten abfragen
von: fcs
Geschrieben am: 16.08.2015 21:13:35
Hallo Smanb,
hier 3 Formelbeispiele, wie es funktionieren sollte.
Tabelle6

 C
140
240
340

Formeln der Tabelle
ZelleFormel
C1=WENN(ODER(ISTZAHL(VERGLEICH("N";A6:A36;0)); SUMMENPRODUKT((B6:B36>=ZEITWERT("21:00"))*(B6:B36<ZEITWERT("22:00"))*1)>0); 40;"")
C2=WENN(SUMMENPRODUKT((ISTZAHL(VERGLEICH("N";A6:A36;0)))+((B6:B36>=ZEITWERT("21:00"))*(B6:B36<ZEITWERT("22:00"))*1))>0;40;"")
C3=(SUMMENPRODUKT((ISTZAHL(VERGLEICH("N";A6:A36;0)))+((B6:B36>=ZEITWERT("21:00"))*(B6:B36<ZEITWERT("22:00"))*1))>0)*40


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Franz

Bild

Betrifft: AW: Spalten abfragen
von: Smanb
Geschrieben am: 16.08.2015 21:31:52
hab es gerade mit der SUMMENPRODUKT-Formel gelöst...
nun möchte ich noch folgendes erreichen...ich hoffe ich drücke mich richtig aus...
In Spalte B stehen meine Arbeitstage, in Spalte H die gearbeiteten Stunden an dem Tag. Ich möchte in Zelle P17 nun meine Zuschläge berechnen: wenn in Spalte B ein So (Sonntag) steht, dann mulitpliziere die Stunden in Spalte H (die in der selben Zeile mit So stehen) mit 3,86.
Kenne leider keine Funktion die erkennt dass die in der selben Zeile stehen müssen :(

Bild

Betrifft: AW: Spalten abfragen
von: SF
Geschrieben am: 16.08.2015 21:32:23
Hola,
um noch mehr Doppelarbeit zu vermeiden....
http://www.office-fragen.de/index.php/topic,31849.0.html
Gruß,
steve1da

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Spalten abfragen"