Logik Problem

Bild

Betrifft: Logik Problem
von: Pit
Geschrieben am: 24.08.2015 15:11:02

Hi,
versuche gerade meine alten Matrixformeln in Summenprodukt zu überführen und habe ein Verständnisproblem:
=SUMMENPRODUKT((A1:A10=4)*(B1:B10={2.3.4})*(C1:C10))
behandelt (B1:B10={2.3.4}) als "ODER".
Ergebnis = 80
Bei
=SUMMENPRODUKT((A1:A10={2.4.5})*(B1:B10={2.3.4})*(C1:C10))
wird A1:A10={2.4.5} allerdings nicht als "ODER" gewertet?
Ergebnis = 10
Tabelle:
2 3 10
4 4 10
5 3 10
4 2 10
4 2 10
4 3 10
4 2 10
4 2 10
4 2 10
4 2 10
Ich kapiere es nicht, kann mir jemand die Logik erklären?
Vielen Dank
Pit

Bild

Betrifft: AW: Logik Problem
von: Rudi Maintaire
Geschrieben am: 24.08.2015 15:59:05
Hallo,
wenn man die sich ergebenden Matrizen auflöst, sieht das so aus:

A1:A10=4   B1:B10={2.3.4} (A1:A10)*(B1:B10) (A1:A10)*(B1:B10)*10 
FALSCH   FALSCHWAHRFALSCH FALSCHFALSCHFALSCH 000 
WAHR   FALSCHFALSCHWAHR FALSCHFALSCHWAHR 0010 
FALSCH   FALSCHWAHRFALSCH FALSCHFALSCHFALSCH 000 
WAHR   WAHRFALSCHFALSCH WAHRFALSCHFALSCH 1000 
WAHR   WAHRFALSCHFALSCH WAHRFALSCHFALSCH 1000 
WAHR   FALSCHWAHRFALSCH FALSCHWAHRFALSCH 0100 
WAHR   WAHRFALSCHFALSCH WAHRFALSCHFALSCH 1000 
WAHR   WAHRFALSCHFALSCH WAHRFALSCHFALSCH 1000 
WAHR   WAHRFALSCHFALSCH WAHRFALSCHFALSCH 1000 
WAHR   WAHRFALSCHFALSCH WAHRFALSCHFALSCH 100080
                
                
                
A1:A10={2.4.5} B1:B10={2.3.4} (A1:A10)*(B1:B10) (A1:A10)*(B1:B10)*10 
WAHRFALSCHFALSCH FALSCHWAHRFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH FALSCHFALSCHWAHR FALSCHFALSCHFALSCH 000 
FALSCHFALSCHWAHR FALSCHWAHRFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH WAHRFALSCHFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH WAHRFALSCHFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH FALSCHWAHRFALSCH FALSCHWAHRFALSCH 0100 
FALSCHWAHRFALSCH WAHRFALSCHFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH WAHRFALSCHFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH WAHRFALSCHFALSCH FALSCHFALSCHFALSCH 000 
FALSCHWAHRFALSCH WAHRFALSCHFALSCH FALSCHFALSCHFALSCH 00010

Alles klar?
Gruß
Rudi

Bild

Betrifft: AW: sorry, hab zu spät angefangen owT
von: ... neopa C
Geschrieben am: 24.08.2015 16:00:37
Gruß Werner
.. , - ...

Bild

Betrifft: AW: sorry, hab zu spät angefangen owT
von: Pit
Geschrieben am: 24.08.2015 16:49:10
Vielen Dank für die schnelle Hilfe!
da war ich ziemlich daneben mit meinem Ansatz^^
Pit

Bild

Betrifft: AW: nicht wirkklich ...
von: ... neopa C
Geschrieben am: 24.08.2015 15:59:44
Hallo Pit,
... wenn Du z.B. die Formel so: =SUMMENPRODUKT((A1:A10={2.4.5})*(B1:B10<>2)*(C1:C10)) schreibst, wirst Du erkennen, dass auch hier {2.4.5} wie ein ODER wirkt. In Deiner Formel wirkt sich zu der jeweiligen ODER-Beziehung wieder die UND-Beziehung durch die "*" -Verknüpfung" so aus, dass ein von Dir ungewolltes Ergebnis aber korrektes Ergebnis erscheint.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Logik Problem
von: Pit
Geschrieben am: 24.08.2015 16:57:24
Vielen Dank für die schnelle Hilfe!
war ich Gedanklich komplett falsch unterwegs^^
Lieben Gruß
Pit

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Logik Problem"