Problem mit Filter

Bild

Betrifft: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 14:37:55

Hallo an euch alle,
ich habe leider ein Problem für das ich keine Beispieltabelle geben kann, da interessanterweise sobald ich nur die für das Problem relevanten Zeilen auswähle, besteht das Problem nicht mehr. Aber ich brauche nunmal die komplette Tabelle.
Es gibt eine Spalte D mit Zellen die entweder leer sind oder den Buchstaben S beinhalten,
dazu die Spalten K und L die entweder ein Kalenderdatum haben oder leer sind.
In Spalte N habe ich folgende Formel
=WENN(D1="";RANG(K1;L$1:L1;0);"")
Das Ganze berechnet genau das was ich haben will.
Möchte ich jetzt allerdings auf Spalte N einen Filter anwenden, in meinem Fall auf Zahlen kleiner gleich 30, wird mir nur ein Textfilter angeboten, kein Zahlenfilter.
Das Zellformat ist Zahl das hab ich bereits überprüft und die RANG Formel müsste ja auch eine Zahl ausgeben.
Woran könnte das liegen?
Viele Grüße
Christian

Bild

Betrifft: AW: Problem mit Filter
von: Hajo_Zi
Geschrieben am: 29.08.2015 14:40:05
Halo Christian,
auch Text kann als Zahl formatiert werden. Prüfe es mit Typ()


Bild

Betrifft: AW: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 14:42:05
=TYP(N1) gibt 1 aus, also Zahl.
Sorry danke erstmal für den Rat.
Gruß
Christian

Bild

Betrifft: AW: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 14:46:20
kann das evtl. auch mit der Datenmenge zu tun haben? Ich hab hier ne Tabelle, die geht von A1 bis O33787 davon die Spalten H bis O komplett mit Zahlen
Was ich auch nicht verstehe dass die Formel =ANZAHL2(D1:D33787) 33787 ausgibt obwohl geschätzt 1/3 der Zellen leer sind.
Es stand zwar mal in jeder Zelle ne Formel aber nur bis ich die Werte eingefügt hab.
Viele Grüße
Christian

Bild

Betrifft: AW: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 14:47:01
sorry soll komplett mit Formeln, nicht komplett mit Zahlen heißen

Bild

Betrifft: AW: Problem mit Filter
von: Hajo_Zi
Geschrieben am: 29.08.2015 14:57:14
Leerzeichen ist auch ein Zeichen. Ich hätte ja Anzahl benutzt da nur Zahlen gezählt werden sollen.
Gruß Hajo

Bild

Betrifft: AW: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 15:00:02
Hallo hajo,
nein nicht ganz in D steht nichts oder ein S.
Mit nichts mein ich auch kein Leerzeichen, einfach nichts.
Demnach gibt =ANZAHL(D:D) 0 aus.
Gruß
Christian

Bild

Betrifft: AW: Problem mit Filter
von: Hajo_Zi
Geschrieben am: 29.08.2015 15:04:20
Hallo Christian,
dann habe ich es wohl falsch verstanden.
Ich hatte verstanden es wird Dir nur Textfilter angezeigt obwohl es Zahlen sind.
Ich bin dann raus. Da falsch verstanden.
Gruß Hajo

Bild

Betrifft: AW: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 15:08:59
Hallo Hajo, ich hoffe du gibst doch noch nicht auf, wenn ich dir sage, wo das Missverständnis lag.
Bei der Sache mit den Zahlen und dem Filter geht es um Spalte N, in der die Formel =WENN(D1="";RANG(K1;L$1:L1;0);"") steht die entweder nichts oder Zahlen ausgibt.
Das mit der Anzahl ist mir nachträglich aufgefallen und bezieht sich auf Spalte D und hat nichts mit dem Filterproblem zu tun, in der Spalte D sind entweder die Zellen vollkommen leer oder beinhalten ein S.
Gruß
Chrisian

Bild

Betrifft: AW: Problem mit Filter
von: Christian
Geschrieben am: 29.08.2015 15:04:35
allerdings gibt =ZÄHLENWENN(D:D;"S") 26846 aus und =ZÄHLENWENN(D1:D33787;"") gibt 6941 aus macht zusammen die gesuchten 33787.

Bild

Betrifft: Probleme, Probleme
von: Michael
Geschrieben am: 29.08.2015 20:22:10
Hi zusammen,
die Berechnung =WENN(D1="";RANG(K1;L$1:L1;0);"")
ist in zwei Punkten kritisch:
a) was ist, wenn der Wert in Kn nicht in L$1:Ln enthalten ist? Dann spuckt RANG nämlich ein #NV aus.
Abhilfe: eine zusätzliche Verschachtelung mit ISTFEHLER.
b) wenn Dn="" dann Nn=""
Was ist, wenn in Nn "" oder #NV steht?

=WENN(ODER(D1<>"";ISTFEHLER(RANG(K1;L$1:L1;0)));-5;RANG(K1;L$1:L1;0))
ist vielleicht nicht exakt das, was Du benötigst, wird Dir aber einen Denkanstoß geben.
Bei -5 ist die Zeile im Filter bei kleiner 30 vorhanden, wenn Du meinetwegen 1000 einsetzt, draußen.
Wie auch immer, auf die Art und Weise sind IMMER Zahlen vorhanden.
Schöne Grüße,
Michael

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Problem mit Filter"