Diagramm Filtern

Bild

Betrifft: Diagramm Filtern
von: Abu
Geschrieben am: 07.09.2015 14:16:49

Hallo Zusammen,
ich möchte gerne mit Hilfe einer Hilfstabelle filtern so das mein Digramm die gefilterten Daten anzeigt.
Habe diesen Thread gefunden, bin aber nicht in der Lage das auf meine Datei umzumünzen.
https://www.herber.de/forum/archiv/1008to1012/1008335_Diagramm_filtern.html
Wenn ich 5 eingebe dann bleiben alle Felder leer. Ist es auch möglich einen zweiten Filter mit einzubauen?
https://www.herber.de/bbs/user/100062.xlsx
Würde mich über Hilfe sehr freuen.
Beste Grüße
Abu

Bild

Betrifft: AW: Diagramm Filtern
von: Beverly
Geschrieben am: 07.09.2015 15:58:45
Hi,
meinst du so:

Test

 BCDEFGHIJKLMNOPQRSTUVWX
2  Filterwert       Filterwert            
3  5       MGB Depot            
4             =spalte C=spalte D=spalte E=spalte F=spalte G=spalte H=spalte I=spalte J=spalte K=spalte L
5112.12.20154     Early MGB Depot 211.01.2015500000Late0MGB Depot
6211.01.20155     Late MGB Depot 314.01.2016500000Late0Bor Depot
7314.01.20165     Late Bor Depot 415.01.2016500000Late0Bor Depot
8415.01.20165     Late Bor Depot            
9                       

verwendete Formeln
Zelle Formel Bereich N/A
B9=+WENN(ISTLEER(C9);"";SVERWEIS(C9;'C:\Users\sabushab\Desktop\[Bor - Primark HS Reporting_SA.xlsx]Data'!A5:B5;2;WAHR))  
D5: D9=+WENN(ISTLEER(C5);"";SVERWEIS(C5;'C:\Users\sabushab\Desktop\[Bor - Primark HS Reporting_SA.xlsx]Data'!G4:K123;3;WAHR))  
N5:N9{=WENN(ZEILE()-4>SUMME(ISTZAHL(FINDEN($D$3;$D$4:$D$100))*1);"";INDEX(B:B;KKLEINSTE(WENN(ISTZAHL(FINDEN($D$3;$D$4:$D$100)); ZEILE($4:$100)); ZEILE(C1))))}$N$5 
O5:O9{=WENN(ZEILE()-4>SUMME(ISTZAHL(FINDEN($D$3;$D$4:$D$100))*1);"";INDEX(C:C;KKLEINSTE(WENN(ISTZAHL(FINDEN($D$3;$D$4:$D$100)); ZEILE($4:$100)); ZEILE(C1))))}$O$5 
P5:X9=WENNFEHLER(INDEX(D$5: D$100;$N5);"")  
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.07 einschl. 64 Bit





Bild

Betrifft: AW: Diagramm Filtern
von: Abu
Geschrieben am: 07.09.2015 16:50:45
Hallo Beverly,
vielen Dank für deine Mühen. Bin meinem Ziel schon ein bissel näher. Habe das nun eingebaut siehe:
https://www.herber.de/bbs/user/100066.xlsx
Wenn ich keinen Filter setze also D3 leer ist sollten alle Daten angezeigt werden, ist das auch machbar? Ist es auch Möglich noch einen zweiten Filter in L3 einzubauen?
Beste Grüße
Abu

Bild

Betrifft: AW: Diagramm Filtern
von: Beverly
Geschrieben am: 07.09.2015 17:56:24
Hi Abu,
alle anzeigen: baue noch eine WENN-Prüfung ein

{=WENN($D$3<>"";WENN(ZEILE()-4>SUMME(ISTZAHL(FINDEN($D$3;$D$4:$D$100))*1);"";INDEX(C:C; KKLEINSTE(WENN(ISTZAHL(FINDEN($D$3;$D$4:$D$100)); ZEILE($4:$100)); ZEILE(C1))));C5) }

Achtung Matrixformel!!



 Bild

Beiträge aus den Excel-Beispielen zum Thema "Diagramm Filtern"