Wenn funktion

Bild

Betrifft: Wenn funktion
von: Sum
Geschrieben am: 04.10.2015 14:51:11

Hallo zusammen
ich möchte
in L8 eine 1 schreiben wenn in A61 nichts steht und wenn etwas in der zelle steht möchte ich eine 2 schreiben
Danke für eure hilfe
MFG
Sum

Bild

Betrifft: AW: Wenn funktion
von: Hajo_Zi
Geschrieben am: 04.10.2015 14:52:54
=Wenn(A61="";1;2)


Bild

Betrifft: AW: Wenn funktion
von: Daniel
Geschrieben am: 04.10.2015 14:57:01
HI
mit dieser Formel in L8: =Wenn(A61="";1;2)
oder etwas kreativer: =max(länge(A61)+1;2)
Gruss Daniel

Bild

Betrifft: =1+(A61<>"")
von: WF
Geschrieben am: 04.10.2015 14:58:04
.

Bild

Betrifft: AW: Wenn funktion
von: Sum
Geschrieben am: 04.10.2015 16:46:44
hallo
muss nochmal nachfragen
hab nun die Formel
=WENN(A61="";1;2)
nun muss ich sie aber erweitern
sprich
wenn in A110 etwas steht muss eine 3 geschrieben werden
wenn in A159 etwas steht muss eine 4 geschrieben werden
wenn in A208 etwas steht muss eine 5 geschrieben werden

Bild

Betrifft: AW: Wenn funktion
von: Hajo_Zi
Geschrieben am: 04.10.2015 16:50:13
und was ist mit A61?
was ist wenn in allen Dreien was steht oder nur in 2?
Gruß Hajo

Bild

Betrifft: AW: Wenn funktion
von: Sum
Geschrieben am: 04.10.2015 16:59:18
es soll eigentlich eine Seitenzähler wedern
A61
A110
A159
A208
ist immer die ertse Spalte auf dem Neun Blatt
Also wenn in A61 nichts steht soll 1 geschrieben werden wenn doch etwas darin steht eine 2
wenn in A 110 nichts steht soll eine 2 geschrieben werden wenn doch etwas darin steht eine 3
usw.

Bild

Betrifft: AW: Wenn funktion
von: Hajo_Zi
Geschrieben am: 04.10.2015 17:06:12
benutze die Formel von WF
=1+(A61<>"")+(A110<>"")...
Du wolltest meine Frage nicht beantworten. Falls A110 leer und A159<>"" wird falsch gezählt.
Gruß Hajo

Bild

Betrifft: AW: Wenn funktion
von: Daniel
Geschrieben am: 04.10.2015 17:15:24
Hi
wenn die Seiten kontinuierlich gefüllt werden, dann vielleicht auch einfach:
=Anzahl2(A61;A110;A159;208)+1
Gruss Daniel

Bild

Betrifft: Dann einfacher mit...
von: EtoPHG
Geschrieben am: 05.10.2015 09:53:40
hallo SUM,
mit dieser Formel als 'Seitenzähler' in L8:

=GANZZAHL((VERGLEICH("*";A:A;-1)/49))
Gruess Hansueli

Bild

Betrifft: ...oops ... Offset vergessen...
von: EtoPHG
Geschrieben am: 05.10.2015 09:59:34
Hallo Sum,
Korrektur (ich hab deine Titelzeilen vergessen :-(

=GANZZAHL(((VERGLEICH("*";A:A;-1)-12)/49))
Gruess Hansueli

Bild

Betrifft: AW: Wenn funktion
von: Daniel
Geschrieben am: 04.10.2015 16:58:29
Hi
du kannst mehrere Wenn-Funktionen schachteln:

=Wenn(A208<>"";5;wenn(A159<>"";4;Wenn(A110<>"";3;wenn(A61<>"";2;1))))
die Reihenfolge entscheidet hier über die Priorität, dh wenn in A208 und in A159 etwas steht, wird trotzdem nur die 5 als erste zutreffende Bedingung angezeigt.
wenn immer nur der höchstwertige Wert angezeigt werden soll, könnte man auch Idee von WF aufgreifen:
=Max(1;(A61<>"")*2;(A110<>"")*3;(A159<>"")*4;(A208<>"")*5)
Gruss Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn funktion"