Zählewenn

Bild

Betrifft: Zählewenn
von: Pottblume
Geschrieben am: 13.10.2015 18:06:02

Hallo zusammen,
ich würde gerne die Spalte B und E untersuchen und zwar dahingehend, wieviele Einträge in der Zeit von 06:00:00 Uhr bis 07:00:00 Uhr waren (Zelle J2) und wieviele davon mit dem Eintrag i.O (Zelle K2) waren und natürlich entsprechend der folgenden Zeiten von 07:00:00 bis 08:00:00 usw.Kann mir da jemand helfen?
https://www.herber.de/bbs/user/100751.xls
Vielen Dank und Gruß
Frank

Bild

Betrifft: AW: Zählenwenn
von: WalterK
Geschrieben am: 13.10.2015 18:45:06
Hallo Frank,
eine Version (wenns immer stundenweise ist):

=SUMMENPRODUKT((WERT(TEXT($B$2:$B$20;"hh:mm:ss"))>=I2)*(WERT(TEXT($B$2:$B$20;"hh:mm:ss"))
Servus, Walter

Bild

Betrifft: AW: Zählenwenn
von: Pottblume
Geschrieben am: 13.10.2015 18:52:52
Hallo Walter,
danke für deine Rückmeldung, aber ist ist nicht ganz das was ich gerne hätte.
Ich würde gerne zunächst ermitteln (Zelle J2) wieviele Einträge in der Zeit von 06:00:00 bis 07:00:00 vorhanden sind und dann wieviele von diesen Einträgen i.O sind (Zelle K2)
Sprich für den ersten Wert in Zelle J2 müsste 3 die Antwort sein und unter i.O in Zelle K2 = 3
Gruß
Frank


Bild

Betrifft: AW: Zählenwenn
von: WalterK
Geschrieben am: 13.10.2015 18:59:53
Hallo Frank,
in J2:


=SUMMENPRODUKT((WERT(TEXT($B$2:$B$20;"hh:mm:ss"))>=I2)*(WERT(TEXT($B$2:$B$20;"hh:mm:ss"))

in K2:

=SUMMENPRODUKT((WERT(TEXT($B$2:$B$20;"hh:mm:ss"))>=I2)*(WERT(TEXT($B$2:$B$20;"hh:mm:ss"))
Servus, Walter

Bild

Betrifft: Einfacher geht's so, ...
von: Luc:-?
Geschrieben am: 13.10.2015 19:28:43
…Folks:
J2[:J9]:=SUMMENPRODUKT(--(STUNDE(B$2:B$20)=STUNDE(I2)))
K2[:K9]:=SUMMENPRODUKT((STUNDE(B$2:B$20)=STUNDE(I2))*(E$2:E$20=K$1))
L2[:L9]:=J2-K2
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Einfacher geht's so, ...
von: Pottblume
Geschrieben am: 14.10.2015 09:16:52
Hallo zusammen,
klasse vielen Dank!! Jetzt hab ich nur noch ein Problem und zwar mit der Uhrzeit 00:00:00 (siehe Zeile 8). Die Formel sagt ja „nehme alle Werte der Spalte B, von B2:B10000 und schaue nach wieviele Einträge vorhanden und wieviele davon =K1 sind. Bis dahin auch alles super. Problem habe ich wie gesagt mit der 00:00:00 da die Formel hier alle „leeren Zellen“ auch mitzählt und mir so ein Ergebnis von 9982 (ZelleJ8) statt 4 gibt (i.O und n.i.O – passt, da ist alles okay). Sprich wie kriegen wir die Formel so hin, dass xls die leeren Zellen nicht unter 00:00:00 heranzieht?
https://www.herber.de/bbs/user/100769.xls
Nochmal allen vielen Dank für die Hilfe 
Gruß
Frank

Bild

Betrifft: AW: Einfacher geht's so, ...
von: Bernd
Geschrieben am: 19.10.2015 16:05:13
Hallo Frank,
ergänz die Formel wie folgt:
=SUMMENPRODUKT(--(STUNDE(B$2:B$10000)=STUNDE(I8))*($B$2:$B$10000<>""))
Hier am Beispiel der Zelle J8 (da wo Dein Ergebnis bisher 9982 ist).
Viele Grüße
Bernd

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Adresse des x-größten Wertes"