Rundung in Abhängigkeit Gesamtsumme

Bild

Betrifft: Rundung in Abhängigkeit Gesamtsumme
von: Max K.
Geschrieben am: 27.10.2015 12:29:13

Hallo,
ich benötige eure Hilfe.
In einem Tabellenblatt werden in 2 Spalten (bspw. A und B) Summen gebildet, die beide für sich so aufgerundet werden sollen, daß die Addition beider Summen eine Rundung auf volle 100 ergibt.
Beispiel: Summe A = 150, Summe B = 150 - keine Rundung erforderlich da Addition volle 100 (300) ergibt
Beispiel: Summe A = 100, Summe B = 120, Rundung bei B auf volle Hundert (200) erforderlich
Beispiel: Summe A = 130, Summe B = 140, Rundung bei A und B auf volle Hundert (je 200) führt zu einem Gesamtergebnis von 400. Bei 130 + 140 (=270) wäre aber gesamt nur auf 300 zu runden.
Abrunden einer Summe ist keine Option, da bspw. die Einzelposition in einer Rechnung falsch wäre oder ein Auszahlungsbetrag für eine Position zu gering ausfällt.
Wie erreiche ich also eine Rundung jeweils in A und B auf volle Hundert, die abhängig von der Rundung der Gesamtsumme A+B funktioniert?
Ehrlich gesagt,.....ich habe keine Ahnung...;-))
Aber vielleicht ja jemand von euch.
Vorab schonmal vielen Dank fürs Nachdenken.
Gruß
Max

Bild

Betrifft: AW: Rundung in Abhängigkeit Gesamtsumme
von: MCO
Geschrieben am: 27.10.2015 13:01:30
Tach!
Das sollte es sein....
Gruß, MCO

Tabelle1

 DEFGHIJK
7 ABSumme Obergrenze AObergrenze BSumme Obergrenze
8        
9 15070220 150100250
10 13080210 150100250
11 11090200 150100250
12 90100190 100100200
13 70110180 100150250
14 50120170 50150200
15 30130160 50150200

verwendete Formeln
Zelle Formel Bereich N/A
I9:J15=OBERGRENZE.GENAU(E9;50)  
G9:G15,K9:K15=SUMME(E9:F9)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit



Bild

Betrifft: AW: Rundung in Abhängigkeit Gesamtsumme
von: Daniel
Geschrieben am: 27.10.2015 13:05:55
Hi
du musst zur Spalte B die Differenz hinzuaddieren, die der Gesamtsumme zur vollen 100 fehlt.
diesen Betrag berechnest du mit:

=Aufrunden(A1+B1;-2)-(A1+B1)
Gruß Daniel

Bild

Betrifft: AW: Rundung in Abhängigkeit Gesamtsumme
von: Max K.
Geschrieben am: 27.10.2015 14:38:49
Hallo Daniel, Hallo MCO,
zunächst vielen Dank für eure Lösungsansätze. Leider bringen sie mich noch nicht so richtig weiter.
@ Daniel
Die Vorgabe die ich erfüllen muss, ist beide Einzelsummen (s. Anlage) so zu runden, dass es im Ergebnis wieder einer gemeinsamen Rundung auf volle Hundert gleicht. Die Differenz beliebig zu A oder B addieren löst daher mein Problem nicht. Was bei einer gemeinsamen Rundung heraus kommen soll, weiß ich ja bereits. Mein Problem ist die jeweilige Rundung der Einzelsummen.
@MCO
Den Ansatz habe ich zwar grob verstanden, aber das Ergebnis (in deinem Ansatz Spalte K) müssen volle Hundert sein. Mit der Anlage wird mein Problem vielleicht besser deutlich.
https://www.herber.de/bbs/user/101065.xls
Gruß
Max

Bild

Betrifft: AW: die Bedingungen sind so nicht realisierbar ...
von: ... neopa C
Geschrieben am: 27.10.2015 14:55:26
Hallo Max,
... jedenfalls nicht so, wie Du es geschrieben hast. Entweder Du lässt für eine Summe eine Abrundung zu oder Du lässt zu, dass die Gesamtsumme größer ist.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Rundung in Abhängigkeit Gesamtsumme
von: Daniel
Geschrieben am: 27.10.2015 15:02:38
Hi
eine Lösung wäre, einen der Werte auf den nächsten vollen Hunderer auf- und den anderen Wert abzurunden:
für den A-Wert:

=Wenn(Rest(A1;100)>Rest(B1;100);Aufrunden(A1;-2);Abrunden(A1;-2))
für den B-Wert:
=Wenn(Rest(A1;100)>Rest(B1;100);Abrunden(B1;-2);Aufrunden(B1;-2))
damit wird der Grössere Wert auf und der kleinere Wert abgerundet, so dass die Summe auf den aufgerundeten Wert der Gesamtsumme kommt.
Gruß Daniel

Bild

Betrifft: AW: Max hatte jedoch eindeutig geschrieben ...
von: ... neopa C
Geschrieben am: 27.10.2015 15:09:02
Hallo Daniel,
... und zwar in seinem Eingangsfragestellung: "Abrunden einer Summe ist keine Option". Deshalb ja auch meine Beitrag von vorhin.
Gruß Werner
.. , - ...

Bild

Betrifft: Erledigt
von: Max K.
Geschrieben am: 27.10.2015 17:47:48
Hallo,
nochmals Dank an alle Beteiligten für das gemeinsame Grübeln..;-))
neopa C hat wahrscheinlich Recht, dass die Vorgabe so nicht realisierbar
ist.
Aber die Vorgabe ist nicht meine Idee, ich sollte es nur "mal eben" umsetzen.
Ich fand den Ansatz schon unlogisch, wollte aber trotzdem mal die Profi`s hier
im Forum gefragt haben. Manchmal hat man ja ein Brett vor dem Kopf.
Danke für eure Mühe! Ich versuche es irgendwann nochmal mit einer sinnvolleren Frage...;-))

Gruß
Max

Bild

Betrifft: Nachtrag
von: MCO
Geschrieben am: 28.10.2015 09:35:08
Moin!
Wenn du die Formel Obergrenze.genau auf das ergebnis erweitert hättest, ist das Ergebnis richtig.
Gruß,MCO

Tabelle1

 EFGHIJKL
7ABSumme Obergrenze AObergrenze BSumme Obergrenze 
8        
915070220 150100300 
1013080210 150100300 
1111090200 150100300 
1290100190 100100200 
1370110180 100150300 
1450120170 50150200 
1530130160 50150200 

verwendete Formeln
Zelle Formel Bereich N/A
G9:G15=SUMME(E9:F9)  
I9:J15=OBERGRENZE.GENAU(E9;50)  
K9:K15=OBERGRENZE.GENAU(SUMME(I9:J9);100)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit



Bild

Betrifft: AW: es sollte auf volle 100 aufgerundet werden owT
von: ... neopa C
Geschrieben am: 28.10.2015 09:45:34
Gruß Werner
.. , - ...

Bild

Betrifft: AW: es sollte auf volle 100 aufgerundet werden owT
von: MCO
Geschrieben am: 28.10.2015 13:12:03
Hallo Werner
Ja..., für mich sieht es in Spalte "K" auch danach aus...
Gruß, MCO

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Rundung in Abhängigkeit Gesamtsumme"