Rang ausgeben von bestimmten Kriterien

Bild

Betrifft: Rang ausgeben von bestimmten Kriterien
von: Malanda
Geschrieben am: 11.11.2015 18:08:39

Hallo!
Ich habe ein kleines Problem, dessen Lösung bestimmt nicht so schwer ist aber ich stehe gerade irgendwie auf dem Schlauch oder habe diesen Formelansatz noch nie zuvor gesehen.
FOLGENDES
Ich habe eine Tabelle in der ich Rangfolgen von gleichen Marken aber abhængig der Verkaufspreise benötige. Beispiel: Spalte A enthält die Namen verschiedener Automarken (BMW, VW, Mercedes) und diesen gegenüber steht in Spalte B der Verkaufspreis jedes einzelnen Modelles. Da natürlich verschiedene Modelle der gleichen Marken vorhanden sind kommt BMW, VW usw mehrmals vor. Ich möchte nun gerne wissen wie die Rangfolge aller BMWs ist, die auf Lager sind entsprechend der Verkaufspreise und eine Reihenfolge nur für alle VWs und alle Mercedes usw. Heisst letztendlich muss es bei drei Marken auch drei mal den ersten Rang geben und drei zweite Ränge usw und so fort.
PLEASE HELP :)

Bild

Betrifft: AW: dafür gäbe es verschiedene Lösungsansätze ...
von: ... neopa C
Geschrieben am: 11.11.2015 18:17:41
Hallo Malanda,
... lade doch mal eine entsprechende kleine Beispieldatei hier hoch und ich schaue es mir Morgen an, falls Du da noch keine Lösung haben solltest. Für Heute gehe ich jetzt gleich oflline.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Rang ausgeben von bestimmten Kriterien
von: fcs
Geschrieben am: 11.11.2015 18:26:49
Hallo Malanda,
Teile Marke und Model auf 2 Spalten auf.
Die weitere Auswertung kann man dann als Pivot-Tabellemnbericht machen, wobei dann bei der Sortierung ggf. eine besondere Einstellung gemacht werden muss, so dass absteigend nach den Preisen/Summe der Preise sortiert wird.
Gruß
Franz

Bild

Betrifft: AW: Rang ausgeben von bestimmten Kriterien
von: Sepp
Geschrieben am: 11.11.2015 21:27:51
Hallo Malanda,
so?
Tabelle3

 ABCDE
1MarkeModellPreisRang 
2Marke 1Modell 1  72.800,00 € 1 
3Marke 1Modell 2  29.200,00 € 6 
4Marke 1Modell 3  72.200,00 € 2 
5Marke 1Modell 4  49.000,00 € 5 
6Marke 1Modell 5  54.200,00 € 4 
7Marke 1Modell 6  60.400,00 € 3 
8Marke 2Modell 1  70.800,00 € 2 
9Marke 2Modell 2  73.000,00 € 1 
10Marke 2Modell 3  24.600,00 € 5 
11Marke 2Modell 4  50.400,00 € 4 
12Marke 2Modell 5  65.200,00 € 3 
13Marke 3Modell 1  48.800,00 € 4 
14Marke 3Modell 2  44.800,00 € 5 
15Marke 3Modell 3  72.000,00 € 1 
16Marke 3Modell 4  68.600,00 € 2 
17Marke 3Modell 5  60.000,00 € 3 
18     

Formeln der Tabelle
ZelleFormel
D2=SUMMENPRODUKT(($A$2:$A$17=A2)*($C$2:$C$17>C2))+1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Sepp


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Rang ausgeben von bestimmten Kriterien"