Teil von Zahlen vergleichen

Bild

Betrifft: Teil von Zahlen vergleichen
von: Hembach
Geschrieben am: 20.11.2015 11:22:19

Hallo zusammen,
ich habe in einer Spalte verschiedene Nummern für Werkzeuge aufgelistet. Die Nummern sind unterschiedlich lang, also mal 4 mal 5 mal 6 Ziffern etc.... Die letzten beiden Ziffern dieser Nummern geben Aufschluss darüber welche Version es von dem Werkzeug ist. Ich möchte jetzt in einer Zelle hinter der Werkzeugnummer die Anzahl der Versionen zu dem Werkzeug angeben. Dazu müsste ich ja dann alle Zahlen der Spalte miteinander vergleichen, nur die letzten beiden Ziffern der Zahlen außen vor lassen.
Ist das und wenn ja, wie ist über Excel möglich?
Ich hoffe ich konnte es einigermaßen verständlich erklären.
Vielen Dank im Voraus!
Schönen Gruß

Bild

Betrifft: AW: Teil von Zahlen vergleichen
von: Rudi Maintaire
Geschrieben am: 20.11.2015 11:27:58
Hallo,
=SUMMENPRODUKT((GANZZAHL($A$2:$A$100/100)=GANZZAHL(A2/100))*1)
Gruß
Rudi

Bild

Betrifft: AW: Teil von Zahlen vergleichen
von: Matthias L
Geschrieben am: 20.11.2015 11:29:22
Hallo
Tabelle1

 AB
18702828702
21321901321
32500072500
44000504000
52316292316
635613356
72659052659
83061643061
94209974209
1075388753

Formeln der Tabelle
ZelleFormel
B1=LINKS(A1;LÄNGE(A1)-2)
B2=LINKS(A2;LÄNGE(A2)-2)
B3=LINKS(A3;LÄNGE(A3)-2)
B4=LINKS(A4;LÄNGE(A4)-2)
B5=LINKS(A5;LÄNGE(A5)-2)
B6=LINKS(A6;LÄNGE(A6)-2)
B7=LINKS(A7;LÄNGE(A7)-2)
B8=LINKS(A8;LÄNGE(A8)-2)
B9=LINKS(A9;LÄNGE(A9)-2)
B10=LINKS(A10;LÄNGE(A10)-2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Jetzt einfach zählen
Gruß Matthias

Bild

Betrifft: hier mal etwas konkreter ...
von: Matthias L
Geschrieben am: 20.11.2015 11:39:26
Hallo
Tabelle1

 ABC
18702828702Version 1
21321901321Version 1
32500072500Version 1
44000504000Version 1
58702838702Version 2
635613356Version 1
72659052659Version 1
88702848702Version 3
94209974209Version 1
1075388753Version 1

Formeln der Tabelle
ZelleFormel
B1=LINKS(A1;LÄNGE(A1)-2)
C1=ZÄHLENWENN($B$1:$B1;B1)
B2=LINKS(A2;LÄNGE(A2)-2)
C2=ZÄHLENWENN($B$1:$B2;B2)
B3=LINKS(A3;LÄNGE(A3)-2)
C3=ZÄHLENWENN($B$1:$B3;B3)
B4=LINKS(A4;LÄNGE(A4)-2)
C4=ZÄHLENWENN($B$1:$B4;B4)
B5=LINKS(A5;LÄNGE(A5)-2)
C5=ZÄHLENWENN($B$1:$B5;B5)
B6=LINKS(A6;LÄNGE(A6)-2)
C6=ZÄHLENWENN($B$1:$B6;B6)
B7=LINKS(A7;LÄNGE(A7)-2)
C7=ZÄHLENWENN($B$1:$B7;B7)
B8=LINKS(A8;LÄNGE(A8)-2)
C8=ZÄHLENWENN($B$1:$B8;B8)
B9=LINKS(A9;LÄNGE(A9)-2)
C9=ZÄHLENWENN($B$1:$B9;B9)
B10=LINKS(A10;LÄNGE(A10)-2)
C10=ZÄHLENWENN($B$1:$B10;B10)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Spalte(3) ist formatiert als Benutzerdefiniert: "Version "Standard
Gruß Matthias

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Teil von Zahlen vergleichen"