Jahressummen dynamisch- Excel

Bild

Betrifft: Jahressummen dynamisch- Excel
von: Robert
Geschrieben am: 22.11.2015 00:09:29

Liebe Foren-Community!
Vielleicht könntet ihr mir hier weiterhelfen,mit meinen bisherigen Lösungsansätzen habe ich keine "sinnvolle" Lösung gefunden.
In meiner Exceltabelle (für Berechnung von Jahresbeträgen über einen längeren Zeitraum)ist in der 1. Spalte jeweils das Datum angeführt (pro Monat ein Wert), in der Spalte B stehen Monatsbeträge. Die Spalte A kann mit einem beliebigen Monat starten, ein gesamtes Jahr betreffen und auch z.B. im Monat Februar bereits wieder enden. Gesucht wird jetzt jeweils zum Monat Dezember bzw. wenn die Berechnung bereits früher endet, die jeweilige Jahressumme in Spalte C.
https://www.herber.de/bbs/user/101711.xlsx
Vielen Dank
Liebe Grüße
Robert

Bild

Betrifft: AW: u.a. mit SUMMENPRODUKT() ...
von: ... neopa C
Geschrieben am: 22.11.2015 07:26:40
Hallo Robert,
... in B1: =WENN(JAHR(A2)=JAHR(A1);"";SUMMENPRODUKT((JAHR(A$1:A$999)=JAHR(A1))*B$1:B$999)) und Formel ziehend nach unten kopieren.
Wenn DU Überschriften in A1:B1 wie z.B. Datum und Wert hättest, könntest Du aber auch mit wenigen Mausklicks eine PIVOTauswertung vornehmen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: u.a. mit SUMMENPRODUKT() ...
von: Robert
Geschrieben am: 22.11.2015 10:31:16
Hallo Werner!
Vielen Dank für die rasche+positive Antwort. Da ich noch zusätzliche Statistiken dazugebe, werde ich Deinen Lösungsansatz mittels Pivot nehmen.
Liebe Grüße
Robert

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wert in ComboBox deaktivieren"