Zeiten automatisch eintragen

Bild

Betrifft: Zeiten automatisch eintragen
von: Tom
Geschrieben am: 22.11.2015 13:21:48

Hallo zusammen,
ich möchte gerne bei der beigefügten Datei https://www.herber.de/bbs/user/101715.xlsx
die Spiele inkl Zeiten automatisch eintragen lassen. Ich hatte schon eimal eine passende Lösung, die Datei ist aber leider nicht mehr auffindbar ...
Evtl kann ja jemand der Experten hier helfen.
Danke vorab.
TOM

Bild

Betrifft: AW: mit SVERWEIS
von: Werner
Geschrieben am: 22.11.2015 17:56:32
Hallo Tom,
Formel in Tabelle Übersicht Zelle F6:
=WENNFEHLER(SVERWEIS($E6;Zeitplan!$A$2:$G$46;4;0);"")
Formel in Tabelle Übersicht Zelle G6:
=WENNFEHLER(SVERWEIS($E6;Zeitplan!$A$2:$G$46;7;0);"")
Die Formeln jeweils so weit nach unten kopieren wie du sie brauchst.
Gruß Werner

Bild

Betrifft: AW: wieder offen
von: Werner
Geschrieben am: 22.11.2015 18:17:19
Hallo Tom,
sehe gerade, dass mein Lösungsvorschlag natürlich Quatsch ist. Du suchst ja die Zeiten und Gegner für die einzelnen Mannschaften, im Beispiel Mannschaft1.
Gruß Werner

Bild

Betrifft: AW: wieder offen
von: Tom
Geschrieben am: 22.11.2015 18:25:17
:-) Habe ich grad in der Originaldatei auch festgestellt ... :-)

Bild

Betrifft: AW: mit SVERWEIS
von: Tom
Geschrieben am: 22.11.2015 18:18:10
Hallo Werner,
vielen Dank.
Das Leben und Excel kann manchmal so einfach sein :-)
Schönes Restwochende!
TOM

Bild

Betrifft: AW: Zeiten automatisch eintragen
von: Sepp
Geschrieben am: 22.11.2015 20:13:21
Hallo Tom,
du musst bei der Schreibweise der Mannschaftsnamen acht geben!
"Mannschaft1" ist nicht gleich "Mannschaft 1" und "Mannschaft1" ist nicht gleich "Mannschaft1 "!
Übersicht

 ABCDEFGHI
1         
2Mannschaft1   Terminübersicht    
3Mannschaft 1 ist nicht Mannschaft1!       
4In 'Zeitplan' hast du Leerzeichen am Ende  Vorrunden-Spiele 
5der Mannschaftsnamen! Kann nich funktionieren   SpielZeitGegnerPause 
6Ansprechpartner:   19:45Mannschaft2  
7    210:15Mannschaft730 min 
8    310:55Mannschaft340 min 
9Teamguide:   411:25Mannschaft630 min 
10    512:05Mannschaft540 min 
11    6    
12Shuttle-Dienst:        
13        
14        

Formeln der Tabelle
ZelleFormel
F6{=WENNFEHLER(INDEX(Zeitplan!$D$2:$D$46;KKLEINSTE(WENN((Zeitplan!$E$2:$E$46=$A$2)+(Zeitplan!$G$2:$G$46=$A$2); ZEILE($A$1:$A$45)); ZEILE(A1))); "")}
G6=WENN(F6="";"";WENN(INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F6;Zeitplan!$D$2:$D$46;0))=$A$2;INDEX(Zeitplan!$G$2:$G$46;VERGLEICH(F6;Zeitplan!$D$2:$D$46;0)); INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F6;Zeitplan!$D$2:$D$46;0))))
F7{=WENNFEHLER(INDEX(Zeitplan!$D$2:$D$46;KKLEINSTE(WENN((Zeitplan!$E$2:$E$46=$A$2)+(Zeitplan!$G$2:$G$46=$A$2); ZEILE($A$1:$A$45)); ZEILE(A2))); "")}
G7=WENN(F7="";"";WENN(INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F7;Zeitplan!$D$2:$D$46;0))=$A$2;INDEX(Zeitplan!$G$2:$G$46;VERGLEICH(F7;Zeitplan!$D$2:$D$46;0)); INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F7;Zeitplan!$D$2:$D$46;0))))
H7=WENN(F7="";"";F7-F6)
F8{=WENNFEHLER(INDEX(Zeitplan!$D$2:$D$46;KKLEINSTE(WENN((Zeitplan!$E$2:$E$46=$A$2)+(Zeitplan!$G$2:$G$46=$A$2); ZEILE($A$1:$A$45)); ZEILE(A3))); "")}
G8=WENN(F8="";"";WENN(INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F8;Zeitplan!$D$2:$D$46;0))=$A$2;INDEX(Zeitplan!$G$2:$G$46;VERGLEICH(F8;Zeitplan!$D$2:$D$46;0)); INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F8;Zeitplan!$D$2:$D$46;0))))
H8=WENN(F8="";"";F8-F7)
F9{=WENNFEHLER(INDEX(Zeitplan!$D$2:$D$46;KKLEINSTE(WENN((Zeitplan!$E$2:$E$46=$A$2)+(Zeitplan!$G$2:$G$46=$A$2); ZEILE($A$1:$A$45)); ZEILE(A4))); "")}
G9=WENN(F9="";"";WENN(INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F9;Zeitplan!$D$2:$D$46;0))=$A$2;INDEX(Zeitplan!$G$2:$G$46;VERGLEICH(F9;Zeitplan!$D$2:$D$46;0)); INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F9;Zeitplan!$D$2:$D$46;0))))
H9=WENN(F9="";"";F9-F8)
F10{=WENNFEHLER(INDEX(Zeitplan!$D$2:$D$46;KKLEINSTE(WENN((Zeitplan!$E$2:$E$46=$A$2)+(Zeitplan!$G$2:$G$46=$A$2); ZEILE($A$1:$A$45)); ZEILE(A5))); "")}
G10=WENN(F10="";"";WENN(INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F10;Zeitplan!$D$2:$D$46;0))=$A$2;INDEX(Zeitplan!$G$2:$G$46;VERGLEICH(F10;Zeitplan!$D$2:$D$46;0)); INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F10;Zeitplan!$D$2:$D$46;0))))
H10=WENN(F10="";"";F10-F9)
F11{=WENNFEHLER(INDEX(Zeitplan!$D$2:$D$46;KKLEINSTE(WENN((Zeitplan!$E$2:$E$46=$A$2)+(Zeitplan!$G$2:$G$46=$A$2); ZEILE($A$1:$A$45)); ZEILE(A6))); "")}
G11=WENN(F11="";"";WENN(INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F11;Zeitplan!$D$2:$D$46;0))=$A$2;INDEX(Zeitplan!$G$2:$G$46;VERGLEICH(F11;Zeitplan!$D$2:$D$46;0)); INDEX(Zeitplan!$E$2:$E$46;VERGLEICH(F11;Zeitplan!$D$2:$D$46;0))))
H11=WENN(F11="";"";F11-F10)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
https://www.herber.de/bbs/user/101731.xlsx
Gruß Sepp


Bild

Betrifft: AW: Zeiten automatisch eintragen
von: Tom
Geschrieben am: 22.11.2015 20:27:26
Brutal ... Danke !!!
Ja das mit den Leerzeichen usw ist passiert, weil ich die original Teams umbennat habe.
SUPER!
DANKE nochmal
Gruß
TOM

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeiten automatisch eintragen"