sverweis

Bild

Betrifft: sverweis
von: Chris
Geschrieben am: 23.11.2015 16:51:58

Hallo
ich habe in Spalte A mehrere Prozentwerte. In einer matrix habe ich die Prozente unterteilt in 0%-25%,25%-50%,50%-75% und 75%-100%. Die Bereiche sind von Q1 bis Q4 gekennzeichnet. Wenn der prozentuale Wert in Spalte A im Bereich von Q1 liegt (0%-25%) soll das in Spalte B mit Q1 angezeigt werden. Ich habe das schon mit sverweis versucht, hat nicht funktioniert, wahrscheinlich weil ich nicht weiß, wie man Bereiche angibt...?

Bild

Betrifft: AW: sverweis
von: SF
Geschrieben am: 23.11.2015 16:53:36
Hola,
das klingt nach einem Sverweis mit 4. Parameter WAHR.
Leider sehen wir nicht, wo deine Matrix steht und in welchem Format die Prozent-Bereiche eingetragen sind.
Gruß,
steve1da

Bild

Betrifft: AW: sverweis
von: Chris
Geschrieben am: 23.11.2015 17:10:00
Danke hat geklappt! :)

Bild

Betrifft: AW: sverweis
von: Daniel
Geschrieben am: 23.11.2015 17:16:32
Hi
bei dieser einfachen gleichmässigen Verteilung geht's auch so:

="Q"&Aufrunden(A1*4;0)

wenns nur 4 Werte sind, kann man auch die Hilfstabelle sparen und mit der Funktion VERWEIS die Werte direkt eingeben:
=VERWEIS(A1;{0;0,25;0,5;0,75};{"Q1";"Q2";"Q3";"Q4"})
wenn du mit dem SVerweis arbeiten willst, müsstest du eine Hilfstabelle erstellen beispielsweise in den Zellen E1:F4 mit folgendem Inhalt:
0,00 | Q1
0,25 | Q2
0,50 | Q3
0,75 | Q4
und dann folgende SVerweis-Formel:
=SVerweis(A1;$E$1:$F$4;2;wahr)
zu beachten ist, dass der Zellbezug auf die Liste absolut gesetzt werden muss (Dollarzeichen, oder bei der Eingabe F4 drücken), damit dieser Zellbezug immer fest auf diesen Zellen bleibt, wenn du die Formel nach unten ziehst.
Gruß Daniel

Bild

Betrifft: Aufrunden und SVerweis ergeben aber nicht ...
von: Luc:-?
Geschrieben am: 23.11.2015 21:06:51
…dasselbe bei den Grenzwerten, Daniel:

 ABCDEFG
1AnteilIntervallDanielvonbis unterIntervall-Mx
225%Q2Q2Q1025%Q1
324%Q1Q1Q125%50%Q2
475%Q4Q4Q350%75%Q3
574%Q3Q3Q375%100%Q4
6B2[:B5]: {=INDEX(G$2:G$5;MAX((A2≥E$2:E$5)*(A2<F$2:F$5)*ZEILE(A$1:A$4)))}
7C2[:C5]:=SVERWEIS(A2;$E$2:$G$5;3)D2[:D5]:="Q"&AUFRUNDEN(A2*4;0)
Die blaue Fml und ihre Ergebnisse dienen der Demo des SVERWEIS-Vorgangs.
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Aufrunden und SVerweis ergeben aber nicht ...
von: Daniel
Geschrieben am: 23.11.2015 22:50:54
Da die Fragestellung an dieser Stelle nicht eindeutig ist und offen lässt zu welchem Q-Wert der benannte Grenzwert gehört, sind beide Varianten möglich und man kann sich das passende raus suchen.
Gruß Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "sverweis"