Tagesverfügbarkeit

Bild

Betrifft: Tagesverfügbarkeit
von: Toma
Geschrieben am: 28.11.2015 12:12:43

Hallo Leute!
Ich habe ein Problem...
am besten erkläre ich euch das in der Datei.
https://www.herber.de/bbs/user/101867.xlsx
Vielen DANK
Gruß
ToMa

Bild

Betrifft: AW: Tagesverfügbarkeit
von: hary
Geschrieben am: 28.11.2015 12:29:19
Moin
Meinst du so? E4 F4 Formel runterziehen.



Einkauf

 EF
1Verbrauch gesamtnoch Haben
225764060
3  
4100

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
E2=SUMMEWENNS(C4:C64;A4:A64;"<="&HEUTE())  =SUMIFS(R[2]C[-2]:R[62]C[-2],R[2]C[-4]:R[62]C[-4],"<="&TODAY())
F2=SUMMEWENNS(B4:B64;A4:A64;"<="&HEUTE())  =SUMIFS(R[2]C[-4]:R[62]C[-4],R[2]C[-5]:R[62]C[-5],"<="&TODAY())
E4=WENN(A4<=HEUTE();SUMME($C$4:C4);"")  =IF(RC[-4]<=TODAY(),SUM(R4C3:RC[-2]),"")
F4=WENN(A4<=HEUTE();SUMME($B$4:B4)-SUMME($C$4:C4);"")  =IF(RC[-5]<=TODAY(),SUM(R4C2:RC[-4])-SUM(R4C3:RC[-3]),"")

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Bild

Betrifft: AW: Tagesverfügbarkeit
von: Toma
Geschrieben am: 28.11.2015 12:52:03
Hallo Hary!
Vielen Dank für Deine Antwort, es passt alles sehr gut und alles stimmt, aber es gibt ein kleines (vielleicht) Missverständnis, es geht um die Spalte F und nicht so sehr um Spalte B.
Heute wäre in der Zelle F2 1484 €
Danke und Gruss
ToMa

Bild

Betrifft: AW: zu einfach: minus E2 ? ;-))
von: hary
Geschrieben am: 28.11.2015 13:33:16
Moin
In F2
=SUMMEWENNS(B4:B64;A4:A64;"<="&HEUTE())-E2
gruss hary

Bild

Betrifft: AW: zu einfach: minus E2 ? ;-))
von: Toma
Geschrieben am: 28.11.2015 15:23:10
hallo Hary!
DANKE DANKE das passt.
Gruss
toma

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Pfad in einem Makro ändern"