Stundenberechnung

Bild

Betrifft: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 13:32:02

Moin ...
Ich habe mir eine Stundenberechnung geschrieben, die ab 06:01 Stunden eine Pause von 30 Minuten abzieht.
Diese Berechnung ist aber nicht ganz richtig.
Die Pause von 30 Miunten darf erst ab 06.30 Std. abgezogen werden.
Arbeite ich 06:15 Std. sollen 06:00 Std. stehenbleiben, also nur 15 Minuten abgezogen werden.
Bißchen schwierig zu erklären, ich hoffe aber dennoch verständlich ...
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 13:35:26
Userbild

Bild

Betrifft: AW: Stundenberechnung
von: fcs
Geschrieben am: 30.11.2015 14:03:32
Hallo Kuddel,
ersetze in der Formel

ZEIT(0;30;0)

durch
MIN(REST(N12-L12;1)-ZEIT(6;0;0);ZEIT(0;30;0))
Gruß
Franz

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 14:35:33
Hmmmh ... das funktioniert so nicht !
Was mache ich falsch ?
Userbild

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 14:37:53
Moment ... ich glaube ich habe falsche Zellen eingefügt ....

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 14:39:34
SUPER --- Danke ... genial !
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Josef B
Geschrieben am: 30.11.2015 14:51:35
Hallo Kuddel
Hast du nie Arbeitszeiten unter 6 Stunden?
In diesem Fall würde die Formel von Franz nicht richtig rechnen.
Gruss Sepp

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 15:06:12
Doch ... habe ich !
Manchmal 2 oder 3 oder 4 Stunden ...
Aber alle Berechnungen sind so ok !
Userbild

Bild

Betrifft: Abzug nach über 10 Stunden
von: Josef B
Geschrieben am: 30.11.2015 15:29:15
Hallo Kuddel
Ja klar, ich habe erst jetzt auf deinem Bild gesehen, dass du eine WENN-Abfrage davor gestellt hast.
Aber was ist, wenn mehr als 10 Stunden gearbeitet wird.
Müsste da der Abzug nicht auch nach dem gleichen Schema wie bei 6 Stunden erfolgen?
Bei deiner Lösung würde bei 10:15 Arbeitszeit auch wieder eine ganze Stunde abgezogen
Gruss Sepp

Bild

Betrifft: Stundenberechnung mit einer Pause 15 Min bei 6 Std
von: lupo1
Geschrieben am: 30.11.2015 15:47:24
=SUMMENPRODUKT((REST(B1-A1;1)>{0.24.26.36.37}/96)*{1.-1.1.-1.1}*(REST(B1-A1;1)-{0.24.26.36.37}/96) )
zieht ab 6:00 30 Minuten und ab 9:00 weitere 15 Minuten ab (Gesetz).
=SUMMENPRODUKT((REST(B1-A1;1)>{0.24.25}/96)*{1.-1.1}*(REST(B1-A1;1)-{0.24.25}/96))
belässt es bei Deinen gewünschten 15 Minuten ab 6 Stunden. Das geht - bei nur einem Abzug, wie von Dir gewünscht - auch kürzer:
=WENN(A1>25/96;A1-1/96;MIN(A1*{1.0}+{0.1}/4))

Bild

Betrifft: AW: Stundenberechnung mit einer Pause 15 Min bei 6 Std
von: lupo1
Geschrieben am: 30.11.2015 15:51:40
Statt REST(B1-A1;1) für Endzeit - Anfangszeit reicht natürlich auch jeweils A1 als Zeitdauer.

Bild

Betrifft: AW: Stundenberechnung
von: JoeKl
Geschrieben am: 30.11.2015 15:40:31
Hallo,
es gibt noch ein Problem bei einer Dauer > 10h. Die Ist-Zeit verringert sich beim Überschreiten Grenze von 10 Stunden.


Ein     Aus     Ist
10:00	19:59	09:29
10:00	20:00	09:30
10:00	20:01	09:01
Bei einer weiteren Pause von 30 min kann der Ansatz von Franz verwendet werden. Die Berechnung muss 1/24 in der ersten Wenn-Funktion ersetzen.

MIN(REST(N12-L12;1)-ZEIT(9;30;0);ZEIT(1;0;0))
MfG
Joe

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 19:14:20
Jetzt habt Ihr mir so viele Berechnungen geschickt ... nicht ganz einfach für mich ...
Also: Ich arbeite selten über 10 Stunden ... wenn überhaupt.
Es stimmt, dass nach 10 Stunden 1 Stunde Pause abgezogen wird.
Wenn aber doch, dürften bei einer Arbeitszeit von -z.B- 10:35 nur 00:35 Minuten abgezogen werden.
Wie bekomme ich denn beide Möglichkeiten ( 6 Stunden und 10 Stunden ) in eine Formel ?
Das wäre der Hit ...
Danke schon mal ...
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 20:29:11
Schaut mal bitte ... ich habe die Formel angepasst !
Ist jetzt zwar etwas länger ... aber immerhin !
Userbild
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 30.11.2015 20:30:39
Blöd ... passt nicht in der Breite ...

Bild

Betrifft: AW: Stundenberechnung
von: lupo1
Geschrieben am: 01.12.2015 05:54:25
Du möchtest ab 06 Std. im Stundenlohn 15 Minuten lang stehen bleiben, und
Du möchtest ab 10 Std. im Stundenlohn 45 Minuten lang stehen bleiben. Dann:
=SUMMENPRODUKT((A1>{0.24.25.40.43}/96)*{1.-1.1.-1.1}*(A1-{0.24.25.40.43}/96))
Das ergibt:
Dauer davon-netto-gearbeitet
06:00 06:00
06:01 06:00
06:15 06:00
06:16 06:01
10:00 09:45
10:01 09:45
10:45 09:45
10:46 09:46
-----------------------------------------------------
Anmerkung:
Richtig ist gesetzlich eigentlich folgendes (hatte ich schon entspr. gepostet):
Du möchtest ab 06 Std. im Stundenlohn 30 Minuten lang stehen bleiben, und
Du möchtest ab 09 Std. im Stundenlohn 15 Minuten lang stehen bleiben. Dann:
=SUMMENPRODUKT((A1>{0.24.26.36.37}/96)*{1.-1.1.-1.1}*(A1-{0.24.26.36.37}/96))
(hier habe ich jetzt nur die Dauer A1 genommen, so dass Du mit Deiner Angabe gleich rechnen kannst)

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 01.12.2015 09:49:09
Moin ...
Deine Formel funktioniert so nicht ...
Wofür steht bei Dir A1 ?
Userbild
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 01.12.2015 13:33:37
Moin ...
Meine eigene Formel funktioniert einwandfrei ...
Kann die Formel gekürzt werden ?
Lupo: Deine Formel funktioniert so nicht ! Welche Zelle ist bei Dir A1 ?
Userbild
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Josef B
Geschrieben am: 01.12.2015 16:05:46
Hallo Kuddel
Lade doch bitte eine Mappe mit deiner Formel hoch. Mit diesen Bildern kann man leider nicht viel anfangen. Oder sollen wir die Formel aus dem Bild abschreiben, um diese dann zu verkürzen?
Die Formel von Lupo geht davon aus, dass in A1 die Brutto-Arbeitszeit steht.
Statt A1 kannst du natürlich auch die Rest-Formel einfügen.
Gruss Sepp

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 01.12.2015 18:34:53
Moin ... ich weiß nicht, ob das mit dem Hochladen funktioniert ... ?
Bin nicht so firm in dieser Sache ...
https://www.herber.de/bbs/user/101945.xlsx
Gruß Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Josef B
Geschrieben am: 01.12.2015 19:58:50
Hallo Knuddel
Deine Formel ist so oder so etwas Falsch aufgebaut.
Bist du sicher, dass diese immer richtig rechnet?
Ich denke, bei einer Bruttoarbeitszeit von 10:01 "siehe Beispiel" kann das doch nicht stimmen oder?
Sollte da nicht eher die 30 Minuten und noch zusätzlich 1 Minute abgezogen werden?
JANUAR

 LMNOPQR
1310:00 20:01   09:01

Formeln der Tabelle
ZelleFormel
R13=REST(N13-L13;1)-(WENN(REST(N13-L13;1)>10/24;1/24;WENN(REST(N13-L13;1)>ZEIT(6;0;0); MIN(REST(N13-L13;1)-ZEIT(6;0;0); ZEIT(0;30;0)-(WENN(REST(N13-L13;1)>10/24;1/24;WENN(REST(N13-L13;1)>ZEIT(10;0;0); MIN(REST(N13-L13;1)-ZEIT(10;0;0); ZEIT(0;60;0)))))))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruss Sepp

Bild

Betrifft: AW: Stundenberechnung
von: Nordsee-Kuddel
Geschrieben am: 01.12.2015 20:16:09
Hallo Josef ...
" Bist du sicher, dass diese immer richtig rechnet? " NEIN !
" Sollte da nicht eher die 30 Minuten und noch zusätzlich 1 Minute abgezogen werden? " JA !
Ich gebe mir zwar Mühe, aber so ein Excel-Profi bin ich nun doch nicht ...
Ich war und bin glücklich es soweit hinbekommen zu haben, aber noch schöner wäre es,
wenn Du mir die richtige Formel geben könntest !
Danke im vorraus ... Kuddel

Bild

Betrifft: AW: Stundenberechnung
von: Josef B
Geschrieben am: 01.12.2015 21:38:07
Hallo Kuddel
Es gibt nicht einfach DIE richtige Formel.
Entscheidend ist eher was, bei welcher Bedingung berechnet werden soll.
Hier nun die Formel, mit deren Hilfe die Pause nach 10 Stunden Arbeitszeit auch im gleichen Verfahren wie bei 6 Stunden abgezogen wird.
Natürlich könnte man die Formel noch kürzen, aber so ist sie Verständlicher.
Gruss Sepp
JANUAR

 LMNOPQR
909:45 18:23   08:08

Formeln der Tabelle
ZelleFormel
R9=REST(N9-L9;1)-WENN(REST(N9-L9;1)>10/24;MIN(REST(N9-L9;1)-ZEIT(10;0;0); ZEIT(0;30;0)))-WENN(REST(N9-L9;1)>ZEIT(6;0;0); MIN(REST(N9-L9;1)-ZEIT(6;0;0); ZEIT(0;30;0)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Bild

Betrifft: 6 Std: 15 - 10 Std: 45 Min => 1 Std Gesamt
von: lupo1
Geschrieben am: 02.12.2015 05:54:48
R9: =SUMMENPRODUKT((REST(N9-L9;1)>{0.24.25.40.43}/96)*{1.-1.1.-1.1}*(REST(N9-L9;1)-{0.24.25.40.43}/96))
passt meine Formel in Deine Tabelle ein.

Bild

Betrifft: AW: 6 Std: 15 - 10 Std: 45 Min => 1 Std Gesamt
von: Nordsee-Kuddel
Geschrieben am: 02.12.2015 10:40:50
Moin ...
Ich bedanke mich bei Euch Beiden ...
Jetzt passt es ...
Gruß Kuddel und Danke ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Userform Control übergeben"