HERBERS Excel-Forum - das Archiv
Autoausfüllen per Formel
User

Hallo,
folgendes Problem: Suche eine Formel mit der man(n) Zahlenreihen im Intervall von 1 (immer beginnend bei 1) beliebig oft wiederholen kann. Einziger Input ist dabei die Obergrenze. Beispiel für Obergrenze von 3:
Spalte B
Z1: 1
Z2: 2
Z3: 3
Z4: 1
Z5: 2
Z6: 3
usw.
Mit (manuellem) "Autoausfüllen" komme ich hier nicht weiter, da die Obergrenze halt variabel sein soll. D.h., wenn ich in einer Inputzelle die Obergrenze 9 eingebe, soll in A1 "1" stehen, in A2 "2" usw. bis A9 und in A10 die erste Wiederholung beginnen, d.h. wieder "1".

AW: Autoausfüllen per Formel
Rudi

hallo,
Inputzelle: $C$1
A1: =WENN(REST(ZEILE();$C$1)=0;$C$1;REST(ZEILE();$C$1))
Gruß
Rudi

AW: Autoausfüllen per Formel
User

Naja, was soll ich sagen
... ES FUNKTIONIERT SUPER, IST DAS, WAS ICH WOLLTE UND GING SUPERSCHNELL ...
TAUSEND DANK!!!

AW: einfacher z.B. so: =REST(ZEILE()-1;C$1)+1 owT
neopa

Gruß Werner
.. , - ...

Autoausfüllen per Formel
User

Hallo,
folgendes Problem: Suche eine Formel mit der man(n) Zahlenreihen im Intervall von 1 (immer beginnend bei 1) beliebig oft wiederholen kann. Einziger Input ist dabei die Obergrenze. Beispiel für Obergrenze von 3:
Spalte B
Z1: 1
Z2: 2
Z3: 3
Z4: 1
Z5: 2
Z6: 3
usw.
Mit (manuellem) "Autoausfüllen" komme ich hier nicht weiter, da die Obergrenze halt variabel sein soll. D.h., wenn ich in einer Inputzelle die Obergrenze 9 eingebe, soll in A1 "1" stehen, in A2 "2" usw. bis A9 und in A10 die erste Wiederholung beginnen, d.h. wieder "1".

AW: Autoausfüllen per Formel
Rudi

hallo,
Inputzelle: $C$1
A1: =WENN(REST(ZEILE();$C$1)=0;$C$1;REST(ZEILE();$C$1))
Gruß
Rudi

AW: Autoausfüllen per Formel
User

Naja, was soll ich sagen
... ES FUNKTIONIERT SUPER, IST DAS, WAS ICH WOLLTE UND GING SUPERSCHNELL ...
TAUSEND DANK!!!

AW: einfacher z.B. so: =REST(ZEILE()-1;C$1)+1 owT
neopa

Gruß Werner
.. , - ...

Bewerten Sie hier bitte das Excel-Portal