Microsoft Excel

Herbers Excel/VBA-Archiv

KKLEINSTE

Betrifft: KKLEINSTE von: Harald
Geschrieben am: 13.03.2016 12:08:29

Ich benötige die Zellengabe (z.B. A7) von dem ermittelten Wert KKLEINSTE, damit ich den Wert der Zelle links daneben auslesen kann.

  

Betrifft: AW: KKLEINSTE von: Hajo_Zi
Geschrieben am: 13.03.2016 12:26:18


Tabelle1

 B
1789

verwendete Formeln
Zelle Formel Bereich N/A
B1=SVERWEIS(KKLEINSTE(A1:A10;1);A1:B10;2;0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 22.01 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: KKLEINSTE von: Harald
Geschrieben am: 13.03.2016 12:46:43

Ich komme damit noch nicht ganz klar.

Es soll in AG3 der Wert von KKleinste H3, also F3 = 89 stehen. usw. der zweit, dritt ...

Ich hänge die Tabelle mal mit an.
https://www.herber.de/bbs/user/104300.xlsx

Herzlichen Dank im voraus.

Harald


  

Betrifft: AW: KKLEINSTE von: Hajo_Zi
Geschrieben am: 13.03.2016 12:52:28

das mit Links hatte ich überlesen.

http://www.excelformeln.de/formeln.html?welcher=24

Gruß Hajo


  

Betrifft: AW: AGGREGAT() kombiniert mit ZÄHLENWENN() ... von: ... neopa C
Geschrieben am: 13.03.2016 14:54:13

Hallo Harald,

... mit folgender Matrixfunktion(alität)sformel in AG3:

=AGGREGAT(15;6;$C3:$O3/($D3:$P3=X3);ZÄHLENWENN($X3:X3;X3))

die Du nach rechts und unten ziehend kopieren kannst, ermittelst Du das von Dir gewünschte auf Basis Deiner vorliegenden Datenwerte.

Gruß Werner
.. , - ...


  

Betrifft: AW: evtl. noch mit INDEX() klammern ... von: ... neopa C
Geschrieben am: 13.03.2016 16:09:36

Hallo,

... meine Formel von vorhin listet zwar die Wertezahlen den jeweiligen Rang richtig zugeordnet aber bei identischen Rang noch nicht in der gleichen Reihenfolge, sondern da ledig von der kleinsten Ringzahl zur gröbsten (wenn in der Formel das erste Argument (15) durch eine 14 ersetzt wird, dann von der größten zur kleinsten Ringzahl).

Wenn jedoch auch bei gleichem Rang die Auflisting in der gleichen Reihenfolge wie in der Werteerfassung erfolgen soll, dann folgende Formel:

=INDEX(3:3;AGGREGAT(15;6;SPALTE($C3:$O3)/($D3:$P3=X3);ZÄHLENWENN($X3:X3;X3)))

(wie ersichtlich ist hier nur die vorherige Formel noch mit der INDEX()-Funktion "umklammert")


Gruß Werner
.. , - ...


  

Betrifft: AW: KKLEINSTE von: Hajo_Zi
Geschrieben am: 13.03.2016 12:54:06


Tabelle1

 B
1789

verwendete Formeln
Zelle Formel Bereich N/A
B1=SVERWEIS(KKLEINSTE(A1:A10;1);A1:B10;2;0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 22.01 einschl. 64 Bit



GrußformelHomepage