Microsoft Excel

Herbers Excel/VBA-Archiv

Kombinierte Gültigkeitskriterien

Betrifft: Kombinierte Gültigkeitskriterien von: Basti
Geschrieben am: 08.04.2016 13:03:18

Hallo zusammen,

ich möchte 1.) eine Zelle abhängig von einem Wert in einer anderen Zelle sperren.
Also A1 gesperrt wenn B1=0.
Wenn 2.) B1=1 soll in A1 aber eine Auswahlliste verfügbar sein mit z.B. 1,2,3,4

Beides für sich, bekomme ich ohne Probleme über den Gültigkeitsbereich gelöst.Doch bei dem Versuch 1.) und 2.) zu kombinieren scheitere ich.

Kann mir jemand weiterhelfen? Danke

VG Basti

  

Betrifft: AW: mit einer definierten Liste und WENN() ... von: ... neopa C
Geschrieben am: 08.04.2016 13:36:50

Hallo Basti

 ABCDEFGH
121     1
2       2
3       3
4       4
5        

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
A1Liste =WENN(B1=1;List;"") 
Namen in Formeln
ZelleNameBezieht sich auf
A1List=Tabelle4!$H$1:$H$4
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: Kombinierte Gültigkeitskriterien von: UweD
Geschrieben am: 08.04.2016 13:41:09

Hallo


Datenüberprüfung, Benutzerdefiniert
Formel: =(B1=1)*(A1<=4)*(A1>=1)*(B1<>0)

Greift aber nur bei Änderung von A
Wenn in A ein gültiger Wert steht, und dann B auf 0 gesetzt wird, erfolgt KEINE Warnung


Gruß UweD


 

Beiträge aus den Excel-Beispielen zum Thema "Kombinierte Gültigkeitskriterien"